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Before You Start 

 

This course guide accompanies the Level 1 training sessions. Level 1 shows you how to produce 3-D 
models using NURBS geometry. 

In class, you will receive information at an accelerated pace. For best results, practice at a Rhino 
workstation between class sessions, and consult your Rhino reference manual and the Help file for 
additional information. 

Duration: 
3 days 

Course Objectives 
In Level 1, you learn how to: 

• Utilize the features of the Rhino user interface 

• Customize your modeling environment 

• Create basic graphic objects—lines, circles, arcs, curves, solids, and surfaces 

• Model with precision using coordinate input and object snaps 

• Modify curves and surfaces with edit commands 

• Use control point editing to modify curves and surfaces 

• Analyze your model 

• Display any portion of the model 

• Export and import models to and from different file formats 

• Render the model 

The Rhino for Windows Interface 

Rhino uses NURBS for all curve 
and surface geometry. 
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Rhino Basics 

The Rhino for Windows Interface 
Before learning individual tools, we will get acquainted with the Rhino interface. The following 
exercises examine the interface elements used in Rhino: the Rhino window, viewports, menus, 
toolbars, and dialog boxes.  

There are many ways to access the commands in Rhino—the keyboard, menus, and toolbars. We will 
focus on the toolbars in this class. 

To open Rhino: 

 Double-click the Rhino icon from the Windows desktop. 
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The Rhino Screen 
Rhino divides its window into six areas that supply information or prompt you for input.  

Screen Area Description 

Menu Bar Access commands, options, and help. 
Command area Lists prompts, commands you enter, and information displayed by the command. 
Toolbars Access shortcuts to commands and options. 
Graphics area Displays the open model. Several viewports can be displayed. The default viewport layout 

displays four viewports ( Top, Front, Right, Perspective ). 
Viewports Displays different views of the model within the graphics area.  
Status bar Displays the coordinates of the pointer, the status of the model, options, and toggles. 
 

 
Rhino screen 

Watch the command line to find 
out what is happening. Menu bar 

Command 
history window 

Command 
prompt 

 
Standard 
toolbar 
 
 
Graphics area 

 
World axes icon 

Viewport title 

 
Main1 and 
Main2 toolbars 

 
 
 
Status Bar 
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Menus 
Most of the Rhino commands can be found in the menus. 

 
Rhino View menu 

Toolbars 
Rhino toolbars contain buttons that provide shortcuts to commands. You can float a toolbar anywhere 
on the screen, or dock it at the edge of the graphics area 

Rhino starts up with the Standard toolbar docked above the graphics area and the Main1 and Main2 
toolbars docked on the left. 
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Tooltips 
Tooltips tell what each button does. Move your pointer over a button without clicking it. A small yellow 
tag with the name of the command appears. In Rhino, many buttons can execute two commands. The 
tooltip indicates which buttons have dual functions. 

 

Flyouts 
A button on a toolbar may include other command buttons in a flyout toolbar. Usually the flyout 
toolbar contains variations on the base command. After you select a button on the flyout, the flyout 
disappears.  

Buttons with flyouts are marked with a small white triangle in the lower right corner. To open the 
flyout toolbar, hold down the left button for a moment or press both buttons at the same time.  

 

The Lines toolbar is linked to the Main1 toolbar.  

If you hold the left mouse down over the Line button of the Main1 toolbar, the flyout Lines toolbar 
opens. 

Graphics Area  
The Rhino graphics area holding the viewports can be customized to suit your preferences. The 
position of viewports can be arranged in different configurations. 
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Viewports 
Viewports are windows in the display area that show you views of your model. To move and resize 
viewports, drag the viewport title or borders. You can create new viewports, rename viewports, and 
use predefined viewport configurations. Each viewport has its own construction plane that the cursor 
moves on and a projection mode. 

To toggle between a small viewport and one that fills the graphics area, double-click the viewport title. 

 
Rearranged Rhino screen. Command line at the bottom, single maximized viewport, and toolbars 
docked in different locations. 
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Command Area 
The command area displays commands and command prompts. It can be docked at the top or the 
bottom of the screen or it can float anywhere. The command window shows three lines by default. To 
open a window that displays the command history, press F2. The text in the Command History window 
can be selected and copied to the Windows clipboard. 

The Mouse 
In a Rhino viewport, the left mouse button selects objects and picks locations. The right mouse button 
has several functions including panning and zooming, popping up a context-sensitive menu, and 
acting the same as pressing the Enter key. Use the left mouse button to select objects in the model, 
commands or options on the menus, and buttons in the toolbars. Use the right mouse button to 
complete a command, to move between stages of commands, and to repeat the previous command. 
The right mouse button is used to initiate commands from some toolbar buttons. 

Drag with the right mouse button to pan and rotate in viewports. Use the mouse wheel or hold down 
the Ctrl key and drag with the right mouse button to zoom in and out in a viewport. You must press 
and hold the right mouse button down to activate this feature.  

Entering Commands 
Use the command line to type commands, pick command options, type coordinates, type distances, 
angles, or radii, type shortcuts, and view command prompts. 

To enter information typed at the command line, press Enter, Spacebar, or right mouse button over 
a viewport. 

Note: Enter and Spacebar perform the same function. 

Shortcuts are customizable key combinations. You can program the function keys and Ctrl key 
combinations to perform Rhino commands. 

Clickable options 
To use command options, click the option on the command line or type the underlined letter of the 
option and press Enter. (The interior capitalization is meaningless.)  
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Autocomplete command name 
Type the first few letters of a command name to activate the autocomplete command list. When 
enough letters of the command are typed so that it is unique, the command name completes on the 
command line. Press Enter to activate the command once the full command name appears. As you 
type command names, the autocomplete command list appears. As you type more letters, the list is 
narrowed down to the possible commands. Left click on the command in the list to start it. 

 

Repeating commands 
To repeat the last command, right-click in a viewport, or press Enter or spacebar. To repeat previous 
commands, right-click in the command line window and select from a list. 

Canceling commands 
To cancel a command, press Esc or enter a new command from a button or a menu. 

Help 
Press F1 at any time to access Rhino Help. In addition to finding information about each command, 
Rhino help has conceptual information as well as many examples and graphics to help you complete 
your model. When you are stalled for any reason, the first place you should look is the help file. You 
can also access help for a specific command by starting the command and then press F1. 
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View the Command Line History 
The command line history window lists the last 500 command lines from the current Rhino session. 
Press F2 to view the command history. 

 

View Recent Commands 
Right-click the command line to view recently used commands. To repeat the command, select it from 
the popup menu. 
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Exercise 1—Rhino basics 
1 From the File menu, click Open. 

2 In the Open dialog box, select First Model.3dm. 

 You will find this model in the Training folder. If you haven’t copied the files to your hard drive 
from the Training folder on the Rhino CD, you should do this before you proceed. 

  
Two parallel viewports and one perspective viewport. 

 This model contains five objects: a cube, a cone, a cylinder, a sphere, and a rectangular plane. 

 You will not be able to select or move the plane. You will learn about how to do this later. It is just 
there to provide you with a floor underneath the objects. 

 
Open 
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3 From the View menu, click Viewport Layout, then click 4 Viewports. 

  
Three parallel viewports and one perspective viewport 

4 In the Status Bar, click Snap to turn on the grid snap. 

 Grid snap may already be on in your system. Be careful that you do not turn it off instead of on. If 
grid snap is on, the word “Snap” will be black in the status bar. If it is off, the word “Snap” will be 
gray. 

Note: This is an important step. Grid snap only lets your cursor move in certain intervals. In this 
model, by default grid snap is set to one half of a grid line. Grid snap helps you line up your 
objects as if you were building with LEGO blocks. 

5 Click the mouse in the Perspective viewport to make it active. 

 The viewport title highlights when it is active. The active viewport is the viewport where all your 
commands and actions take place. 
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6 Click with the Right Mouse Button (RMB) on the Perspective viewport title, then click Shaded 
Display. 

  
The objects appear shaded. Shaded display lets you preview the shapes. The viewport will remain 
shaded until you change it back to a wireframe view. You can change any viewport to shaded 
mode. Later we will discuss the other shaded display options. 

 
Shaded display. 
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7 From the Render menu, click Render.  

Rendering the model opens a separate render window. The model displays in render colors 
previously assigned to the objects. You can also set lights and a background color. You will learn 
about doing this later. You cannot manipulate the view in the render display window but the image 
can be saved to a file. 

 
Render. 

8 Close the render window. 

9 In the Perspective viewport, click and drag with your right mouse button held down to rotate the 
view. 

The plane helps you stay oriented. If the objects disappear, you are looking at the bottom of the 
plane. 

  
Rotate the view in shaded display. 

10 Right click on the Perspective viewport title, then click Ghosted Display. 

  
Ghosted shade display. 

 
Render 
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11 Right click on the Perspective viewport title, then click X-ray Display. 

  
X-Ray shaded display. 

12 Right click on the Perspective viewport title, then click Rendered Display. 

  
Rendered display. 

13 Change to a Wireframe Display mode. 

14 To rotate your view, drag from the bottom of the view toward the top. 

 
Looking at the objects from the bottom in wireframe mode.  

You are now under the objects looking up. 
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15 Change to a Shaded Display mode. 

The plane obscures the objects.  

 
Looking at the objects from the bottom in shaded mode.  

In shaded mode, the plane helps you see when your viewpoint is below the objects. 

To get back to your original view: 

 Press the Home key to undo your view changes. 

If you are “lost in space” in the perspective view: 

 From the View menu, click Viewport Layout, and then click 4 Viewports. 

This takes you back to the default viewport settings. 

Navigating Around the Model 
You have used the right mouse button to rotate in the Perspective viewport. You can hold Shift and 
drag with the right mouse button to pan. Dragging the right mouse button to move around does not 
interrupt any commands in progress.  

To pan in a viewport: 

1 In the Top viewport, hold Shift and drag with the right mouse button to pan the view. 

 
Panning with Shift and the right mouse button. 

2 Pan the view in the other viewports. 

What if … 

Instead of panning or rotating, 
something funny happened. 

If you right-click quickly once in 
viewport, the last command 
starts again. You must hold the 
right mouse button down while 
panning or rotating.  
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Zooming in and out 
Sometimes you want to get closer to your objects or move back so you can see more. This is called 
zooming. As with many things in Rhino, there are several ways to do this. The easiest way is to hold 
down the Ctrl key and drag up and down in a viewport with the right mouse button. If you have a 
mouse with a scroll button, turn the mouse wheel to zoom in and out. 

To zoom in and out: 

 In the Top viewport, hold the Ctrl key, click and hold the right mouse button, and drag the mouse 
up and down.  

Drag up to zoom in. 

Drag down to zoom out. 

 
Zooming with ctrl and the right mouse button. 

Zooming extents 
The Zoom Extents command zooms a viewport so the objects fill up the viewport as much as possible. 
You can use this command to make everything visible.  

To zoom extents in a viewport: 

 From the View menu, click Zoom, and then click Extents. 

If you get lost, it is often handy to zoom extents in all your viewports at once, so there is a 
command to do just that. 

To zoom extents in all viewports: 

 From the View menu, click Zoom, and then click Extents All. 

 
Zoom Extents 
 
Left click this button. 

 
Zoom Extents All Viewports 
Right click this button 
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Move Objects 
Dragging follows the construction plane of the current viewport. 

Now drag the objects around. You can drag in any viewport. In this model, Snap is set to one-half of a 
grid line. Using this snap, you should be able to line objects up with each other. 

To move objects: 

1 Click the cone and drag it. 

The cone highlights to show it is selected. 

 
The selected cone highlights. 

2 Drag the cone in the Perspective viewport until it lines up with the cylinder. 

It will be inside the cylinder. 

The cone moves on the base that is represented by the grid. This base is called a construction 
plane. Each viewport has its own construction plane. When you start Rhino, the Perspective 
viewport has the same construction plane as the Top viewport. You will learn more about using 
construction planes later. 

 
Drag the cone to move it. 
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3 In the Front viewport, drag the cone to the top of the cylinder. 

Watch what happens in the Perspective viewport. 

There are many times when you have to watch what is happening in other viewports to accurately 
place your objects. 

 
Move the cone in the Front viewport. 

4 Click in the Perspective viewport. 

5 Change the viewport to a Rendered Display. 

 
Rendered Display. 

Try on Your Own 

1 Re-open the model. Do not save changes. 

2 Drag the objects around. 

Use the Front viewport to move the objects vertically and the Top or Perspective viewport to 
move them horizontally. 
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Copy Objects 
To create more objects, copy the shapes.  

To start with a new model: 

1 From the File menu, click Open. 

2 Do not save the changes. 

3 In the Open dialog box, select First Model.3dm. 

To copy objects: 

1 Click the box to select it. 

2 From the Transform menu, click Copy. 

3 At the Point to copy from ( Vertical=No InPlace ) prompt, click somewhere in the Top viewport. 

It usually helps to click a spot that relates to the object like the middle. 

 
Select and copy the box. 

4 At the Point to copy to prompt, click where you want the first copy. 

Zoom in closer if you like.  

5 At the next Point to copy to prompts, click other places to make more copies of the box. 

 
Make three copies 

 
Copy 
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6 When you have enough copies, press Enter. 

 
Shaded display. 

Try on Your Own 

 Make copies of more objects and move them around. See if you can build something. 

Changing the View of Your Model 
When you add detail to your models, you will need to see different parts of your model with different 
magnifications. You can use the view commands, the mouse, and the keyboard to change the view in 
a viewport. 

Each view corresponds to the view through a camera lens. The invisible target of the camera is located 
in the middle of the viewport. 

Viewports  
With Rhino, you can open an unlimited number of viewports. Each viewport has its own projection, 
view, construction plane, and grid. If a command is active, a viewport becomes active when you move 
the mouse over it. If a command is not active, you must click in the viewport to activate it. 

Parallel vs. Perspective Projection  
Unlike other modelers, Rhino lets you work in both parallel and perspective views.  

To toggle a viewport between parallel and perspective view: 

1 Right-click the viewport title, click Viewport Properties.  

2 In the Viewport Properties dialog box, click Parallel or Perspective, and then click OK.  
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Panning and Zooming  
The simplest way to change the view is to hold down the Shift key and drag the mouse with right 
mouse button held down. This pans the view. To zoom in and out, hold down the Ctrl key and drag up 
and down or use the mouse wheel. 

You can also use the keyboard to move around: 

Key Action + Ctrl  

Left Arrow Rotate left Pan left 
Right Arrow Rotate right Pan right 
Up Arrow Rotate up Pan up 
Down Arrow Rotate down Pan down 
Page Up Zoom in  
Page Down Zoom out  
Home Zoom previous  
End Zoom next  

You can change your view in the middle of a command to see precisely where you want to select an 
object or select a point. 

Resetting Your View  
If you get lost, four view techniques can help you get back to a starting place. 

To undo and redo view changes: 

 Click in a viewport, then press your Home or End key on your keyboard to undo and redo view 
changes. 

To set your view so you are looking straight down on the construction plane: 

 From the View menu, click Set View, and then click Plan. 

To bring all your objects into view: 

 From the View menu, click Zoom, and then click Zoom Extents. 

To bring all your objects into view in all viewports: 

 From the View menu, click Zoom, and then click Extents All. 
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Exercise 2—Display options 
 Open the model Camera.3dm.  

 You will use this to practice changing views. You will create views from six directions including the 
oblique perspective view. 
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To change the number of viewports: 

1 Make the Top viewport active. 

2 From the View menu, click Viewport Layout, and then click Split Vertical. 

3 Repeat this step for the other parallel views. 

4 Right click on the Top viewport title on the left, click Set View, then click Bottom. 

5 Right click on the Front viewport title on the left, click Set View, then click Left. 

6 Right click on the Right viewport title on the right, click Set View, then click Back. 

7 From the View menu, click Zoom, and then click Extents All. 

To synchronize the viewports: 

1 Right click on the Front viewport title, click Zoom, and then click Synchronize Views. 

 
All the views are sized to the same scale as the active viewport and aligned with each other.  

 
Split Vertical 
 

 
Bottom View 
 

 
Left View 
 

 
Back View 
 

 
Zoom Extents All 
 

 
Synchronize Views 
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To change the shape of viewports: 

1 Move your cursor to the edge of a viewport until you see the resizing  or  cursor, hold the left 
mouse button down, and drag the bar. If two viewports share the edge, both resize. 

2 Move your cursor to the corner of a viewport until you see the resizing  cursor, hold the left 
mouse, and drag the intersection in any direction. If several viewports touch at that corner, all 
resize. 

To zoom to a window:  

1 From the View menu, click Zoom, and then click Window. 

2 At the Drag a window to zoom ( All Dynamic Extents Factor In Out Selected Target ) prompt, 
drag a window around a portion of the model. 

  

To zoom a selected object:  

1 Select the shutter release. 

2 From the View menu, click Zoom, and then click Selected. 

The view zooms to the selected object. 

  

To rotate the view: 

 In a perspective viewport, drag with right mouse button. 

 In a parallel viewport, use the arrow keys. 

 
Zoom Window 
 

 
Zoom Selected 
 



 

Notes: 

Robert McNeel & Associates 26 

To maximize and restore a viewport: 

1 Double-click the viewport title to maximize it. 

2 Double-click the title of the maximized viewport to restore it to its smaller size and reveal the 
other viewports. 
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Creating Two-Dimensional 
Objects 

Drawing Lines 
The Line, Lines, and Polyline commands draw straight lines. The Line command draws a single line 
segment. The Lines command draws multiple end-to-end line segments. The Polyline command 
draws a series of straight segments joined together (a single linear curve with multiple segments).  

Exercise 3—Drawing lines 
1 From the File menu, click New.  

 Do not save changes. 

2 In the Template File dialog box, click Millimeters.3dm. 

3 From the File menu, click Save As. 

4 In the Save As dialog box, type Lines, and then click Save. 

To draw line segments: 

1 From the Curve menu, click Lines, and then click Line Segments to begin the Lines command. 

2 At the Start of line prompt, pick a point in a viewport. 

3 At the End of line ( Undo ) prompt pick another point in a viewport. 

A line segment appears between the two points. 

4 At the End of line. Press Enter when done ( Undo ) prompt, pick another point. 

You can press the right button instead of pressing the Enter key on your keyboard to terminate 
the command. 

 
Line Segments 
Right-click for Line Segments 
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5 At the End of line. Press Enter when done ( Close Undo ) prompt, continue to pick points. 

Additional segments appear.  

Each segment meets but is not joined to the previous segment. 

Option Description 

Close Closes the shape by drawing a segment from the last point picked to the first point picked. This 
ends the command. 

Undo Deletes the last point picked. 
 

6 At the End of line. Press Enter when done ( Close Undo ) prompt, press Enter to end the 
command. 

To use the Close option: 

1 From the Curve menu, click Lines, and then click Line Segments to begin the Lines command. 

2 At the Start of line prompt, pick a point. 

3 At the End of line ( Undo ) prompt pick another point. 

4 At the End of line. … ( Undo ) prompt, pick another point. 

5 At the End of line. … ( Close Undo ) prompt, click Close. 

The last line will end at the original start point. 

To draw a polyline: 

1 From the Curve menu, click Lines, and then click Polyline to begin the Polyline command. 

2 At the Start of polyline prompt, pick a point. 

3 At the Next point of polyline ( Undo ) prompt pick another point. 

4 At the Next point of polyline. … ( Undo ) prompt, pick another point. 

5 At the Next point of polyline. … ( Close Undo ) prompt, continue to pick points. 

To use the Undo option: 

1 From the Curve menu, click Lines, and then click Polyline to begin the Polyline command. 

2 At the Start of polyline prompt, pick a point. 

3 At the Next point of polyline ( Undo ) prompt pick another point. 

4 At the Next point of polyline. … ( Undo ) prompt, pick another point. 

5 At the Next point of polyline. … ( Close Undo ) prompt, click Undo. 

One segment of the polyline is removed. 

 
Polyline 
Left click for Polyline. 
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6 At the Next point of polyline. …( Undo ) prompt, pick another point. 

7 At the Next point of polyline. … ( Close Undo ) prompt, press Enter to end the command. 

To draw a single line segment: 

1 From the Curve menu, click Lines, and then click Single Line to begin the Line command. 

2 At the Start of line ( Normal Angled Vertical FourPoint Bisector Perpendicular Tangent Extend 
BothSides ) prompt, pick a point. 

3 At the End of line ( BothSides ) prompt, pick another point. 

The command ends after one segment is drawn. 

To use the BothSides option: 

1 From the Curve menu, click Lines, and then click Single Line to begin the Line command. 

2 At the Start of line ( Normal Angled Vertical FourPoint Bisector Perpendicular Tangent Extend 
BothSides ) prompt, click BothSides. 

3 At the Middle of line (Normal Angled Vertical FourPoint Bisector Perpendicular Tangent Extend ) 
prompt, pick a point. 

4 At the End of line prompt, pick another point. 

A segment is drawn with equal length on both sides of the start point. 

 

  
Single Line 
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Drawing Free-form Curves 
The InterpCrv and Curve commands draw free-form curves. The InterpCrv command draws a curve 
through the points you pick. The Curve command uses control points to create a curve. 

Exercise 4—Drawing interpolated curves 
1 From the Curve menu, click Free-form, and then click Interpolate Points. 

2 At the Start of curve ( Degree=3 Knots=SqrtChord StartTangent ) prompt, pick a point. 

3 At the Next point of curve ( Degree=3 Knots=SqrtChord EndTangent Undo ) prompt, pick 
another point. 

4 At the next several Next point of curve ( Degree=3 Knots=SqrtChord EndTangent Close 
Sharp=No Undo ) prompts, pick more points. 

Or, click an option, and press Enter. 

Option Description 

Close Closes the shape by drawing a segment from the last point picked to the first point picked. 
This ends the command. 

EndTangent After choosing a point on another curve, the next segment will be tangent to the point you 
picked and end the command. 

Undo Deletes the last point picked. 
Degree You can set the degree of the curve. 
Knots Determines how the interpolated curve is parameterized. 

When you draw an interpolated curve, the points you pick are converted into knot values on 
the curve. The parameterization means how the intervals between knots are chosen: 

Sharp When you make a closed curve, it will come to a point instead of making a smooth closure as 
it normally does. 

Exercise 5—Drawing curves from control points 
1 From the Curve menu, click Free-form, and then click Control Points. 

2 At the Start of curve ( Degree=3 ) prompt, pick a point. 

3 At the Next point ( Degree=3 Undo ) prompt, pick another point. 

4 At the Next point ( Degree=3 Close Sharp=No Undo ) prompts, pick more points. 

Or, click an option, and press Enter. 

 
Interpolated Points 
 

 
Control Point Curve 
 

Notice that most of the points you 
pick are off the curve as control 
points. 



 

Notes: 

Robert McNeel & Associates 33 

Modeling Aids 
Modes are modeling aids that you can toggle on or off by pressing shortcut keys, a function key, 
typing a single letter command, or clicking a button.  

 
Mode 

Function 
Key 

 
Description 

Ortho F8 or Shift  Ortho on restricts cursor movement to the points at a specified angle from the last point 
created. The default angle is 90 degrees. 
Pressing and holding the Shift key down toggles Ortho. If Ortho is set to on, hold down 
the Shift key to toggle Ortho off. If Ortho is off, hold down the Shift key to toggle Ortho on. 

Grid F7 Hides or shows a reference grid in the current viewport of the graphics screen at the 
construction plane. 

Snap F9 or S Forces the marker to snap on grid intersections. 
Planar P This is a modeling aid similar to Ortho. This helps you model planar objects by forcing 

input to be on a plane parallel to the construction plane that passes through the last point 
that you picked. 

Click the Snap, Ortho, and Planar panes on the status bar to toggle these modeling aids on and off. 

 

Exercise 6—Drawing lines and curves using mode functions 
1 Toggle Snap on and draw some lines. 

The marker snaps to each grid intersection. 

2 Toggle Snap off, toggle Ortho on and draw some lines and curves. 

You can only input points that are at 90 degree intervals from the last point. Using Snap and 
Ortho toggles you can draw with precision. We will discuss other ways to get precision in a later 
session. 
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Model Setup  
In Rhino you can create full-size models using precise measurements. You might need to change the 
modeling environment depending on the type of model you are creating; the default options may not 
always work.  

To change the options: 

1 From the File menu, click Properties. 

2 In the Document Properties dialog box, under Rhino Options, click Modeling Aids. 

Modeling Aids lets you control Ortho, Object Snap, Grid Snap, and other mode options. 

 
3 Change the Ortho option to snap every 30 degrees. 

 
Document Properties 
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4 In the Document Properties dialog box, click Grid. 

 
5 In Grid properties, change the following settings. 

You can change the appearance of the modeling environment by changing the grid elements. The 
grid spacing, the frequency of the major lines, and the number of grid elements can be changed. 
The Grid dialog box lets you configure grid settings. 

6 Change the Grid Extents setting to 10. 

7 Change the Minor grid lines every setting to 1. 

8 Change the Major lines every setting to 4. 

9 Change the Snap Spacing setting to .25, and click OK. 

10 Draw some more lines and curves with Snap and Ortho on. 

Notice that the marker now snaps between the grid intersections and that Ortho snaps at every 
30 degrees. 

The value for Grid extents is for 
each quadrant. 
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11 Try to draw the closed polyline below with Snap and Ortho turned on. 

 
12 From the Tools menu, click Options. 

13 In the Document Properties dialog box, click Modeling Aids. 

14 Change the Ortho options to snap every 90 degrees. 

Saving Your Work 
Save your work periodically during a session to keep it from getting accidentally deleted.  

To save your model: 

 From the File menu, click Save. 

Or, click one of the other options. You will have an opportunity to save your work. 

Command Description 

Save Saves your model and keeps it open. 
SaveSmall Save your model without render or analysis meshes and preview image to minimize file 

size. 
IncrementalSave  Save sequentially numbered versions of your model. 
SaveAs Saves your model to a specified file name, location, and format.  
SaveAsTemplate Save as a template. 

 
Save 
 

It is good practice to save your 
model in stages under different 
names, using the Save As 
command. This lets you go back 
to an earlier version of your 
model for modifications if 
necessary. 
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Layers  
Rhino layers work like CAD layering systems. By creating objects on different layers, you can edit and 
view related portions of a model separately or as a composite. You can create as many layers as you 
like. 

You can display all layers simultaneously or turn any of them off. You can lock layers so they are 
displayed but cannot be selected. Each layer has a color. You can assign a name to each layer (for 
example, Base, Body, Top) to organize the model or you can use preset layer names (Default, 
Layer 01, Layer 02, Layer 03).  

The Layers window manages layers. Use it to set up layers for your model. 

 

Exercise 7—Layers  

To create a new layer: 

1 From the Edit menu, click Layers, and then click Layers. 

 
The Default layer is created automatically when you start a new model with no template. If you 
use a standard Rhino template, a few additional layers are also created. 

2 In the Layers window, click New. 

3 The new Layer 06 appears in the list, type Line and press Enter. 

4 Click New. 

5 The new Layer 06 appears in the list, type Curve and press Enter. 

 
Layers 
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To assign a color to a layer: 

1 Click the Color patch on the Line row in the list. 

 
2 In the Select Color dialog box, click Red from the list. 

 The right half of the sample rectangle turns red. 

Hue, Sat, Val are the hue, saturation and value components of the color.  

R, G, and B are the red, green and blue components of the color. 

3 Click OK. 

4 In the Layers window, the new color appears in the color bar on the Line row of the layer list. 

5 Repeat steps 1–3 to make the Curve layer Blue. 

6 Click OK to close the dialog box. 

To make a layer current: 

1 In the Status Bar, click the Layer pane. 

2 In the Layer popup, click Line. 

 Clicking the name or the checkbox sets the current layer. 

3 Draw some lines. 

The lines are on the Line layer and they are colored red. 

Hue is controlled by moving the 
line around the circular portion of 
the color wheel. 

Hue is the color that is referred to 
as a scale ranging from red 
through yellow, green and blue 
and then circularly back to red. 

Saturation and Value are 
controlled by moving the small 
circle around in the square 
portion in the middle of the color 
wheel. 

Saturation is the vividness of 
hue. Value is the relative 
lightness or darkness of a color. 
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4 To make a different layer current, click the Layer pane of the status bar. 

 
5 Click Curve. 

6 Draw some curves. 

They are on the Curve layer and are colored blue. 

7 Draw more lines and curves on each layer. 

To lock a layer: 

1 From the Edit menu, click Layers, and then click Layers. 

2 In the Layers window, click the Lock icon in the row for Line, and click OK. 

Locking a layer turns it into a reference only layer. You can see and snap to objects on locked 
layers. You cannot select any objects on locked layers. You cannot make a locked layer current 
without unlocking it.  

To turn a layer off: 

1 From the Edit menu, click Layers, and then click Layers. 

2 In the Layers window, click the On/Off icon (light bulb) in the row for Curve, and click OK. 

Turning a layer off makes all objects on it invisible. 

Exercise 8—Selecting objects  

To select a single object: 

 Move your pointer arrow over the object and left-click. 

The object turns yellow, which is the default highlight color. 

To select more than one object: 

1 Move your pointer arrow over the first object and left-click. 

2 While holding the Shift key down, move your pointer over another object and left click. 
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To select more than one object using a window: 

1 Move your pointer arrow into an open area to the left of the objects you want to select.  

2 Hold your left mouse button down and drag diagonally to the right until you have several objects 
inside the selection box.  

The window selection box is a solid rectangle 

3 Release your mouse button. 

All objects completely inside the selection box will be selected. 

4 To add to your selection set, hold the Shift key down while making another selection. 

To select more than one object using a crossing window: 

1 Move your pointer arrow into an open area to right of the objects you want to select. 

Hold your left mouse button down and drag diagonally to the left until you have several objects 
inside or touching the box.  

The crossing selection box is a dotted rectangle. 

2 Release your mouse button. 

All objects inside or touching the box will be selected. 

3 To add to your selection set, hold the Shift key down while making another selection. 

To hide an object: 

1 Select an object. 

2 From the Edit menu, click Visibility, and then click Hide. 

The object becomes invisible. 

To show hidden objects: 

 From the Edit menu, click Visibility, and then click Show. 

The Show command redisplays all hidden objects. 

To lock an object: 

1 Select an object. 

2 From the Edit menu, click Visibility, and then click Lock. 

The object becomes shaded gray. You can see the locked object, you can snap to it, but you 
cannot select it. 

  
Hide 
Left click for hide. 

  
Show 
Right click this button. 

  
Lock 
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To unlock locked objects: 

 From the Edit menu, click Visibility, and then click Unlock. 

The Unlock command redisplays all locked objects. 

To change an object from one layer to another: 

1 Select an object. 

2 From the Edit menu, click Layers, and then click Change Object Layer. 

 
3 In the Layer for object dialog box, select the new layer for the object, and click OK. 

  
Unlock 
Right-click for unlock. 

 
Change Layer 
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Deleting Objects 
Delete removes selected objects from the model. Use Delete to practice selection. 

Exercise 9—Practice using delete and selection options 
1 From the File menu, click Open. 

2 In the Open dialog box click Delete.3dm and click Open, or double-click Delete.3dm to open 
the model. 

 
3 Select the square and the circle. 

 
4 From the Edit menu, click Delete or press the Delete key. 

The objects disappear. 

To start the first practice: 

1 Select one of the lines on the hexagon in the Top viewport. 

Because there are several curves superimposed on each other, the selection menu appears, 
allowing you to select one of the curves. 

 
2 Select the top curve from the list. 
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3 From the Edit menu, click Delete. 

Observe one disappear in the Perspective viewport. 

4 In the Top viewport, use a crossing box to select the surface and the polyline in the top right part 
of the drawing. 

Both objects are selected. 

  
5 From the Edit menu, click Delete. 

6 Make a window to select the polyline and the cylinder in the lower right part of the drawing. 

Only those objects that are completely inside the window are selected. 

  
7 From the Edit menu, click Delete. 

8 Continue deleting objects in the drawing.  

Practice using different selection methods to select and deselect objects. Use crossing and 
window. The Shift key while selecting will let you add to your selection set. The Ctrl key while 
selecting will let you to remove objects from your selection set. 

To undo deletions: 

 From the Edit menu, click Undo. 

Each time you click, Undo takes you back one command. 

To redo: 

 From the Edit menu, click Redo. 

Each time you click, the previous Undo is reinstated. 

  
Undo 
Left click for undo. 

  
Redo 
Right-click for redo. 
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4  

 

 

 
 
Precision Modeling 

 
So far you have been drawing imprecise lines. Now you will try drawing lines at specific places. To do 
this you will use coordinates.  

Whenever you draw a curve, or create a solid primitive, Rhino asks you for a series of points. You can 
tell that Rhino is asking for point input two ways: the command prompt has a prompt like Start of 
line, Start of polyline, Start of curve, or Next point and the arrow-shaped cursor turns into a 
cross-shaped cursor.  

You can enter a point two ways: pick a point in a viewport with the mouse, or type coordinates at the 
command line.  

Rhino uses a fixed Cartesian coordinate system called the world coordinate system (WCS), based on 
three axes (the x-, y-, and z-axes) that define locations in three-dimensional space. 

Each viewport has a construction plane that defines coordinates for that viewport. We will work in the 
Top and Perspective viewports where the two coordinate systems are the same.  

Set the units and tolerance of the 
model before you begin. 
 
You can change the tolerance 
after you start, but objects 
created before the change still 
have the old tolerance value. 

 
Cross-shaped cursor 
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Absolute Coordinates 
The first forms of coordinates you will use are called absolute coordinates. Absolute coordinates are 
exact locations relative to the x-, y-, and z-axes.  

Exercise 10Setting up a model  
1 From the File menu, click New. 

2 Click Millimeters.3dm, and then click Open. 

3 From the File menu, click Save As. 

Name the model BOXES. 

 Use the BOXES.3dm model to learn how to draw with absolute coordinates.  

Exercise 11—Entering absolute coordinates 
1 Double-click the viewport title to maximize the Top viewport,. 

2 From the Curve menu, click Lines, and then click Polyline. 

3 At the Start of polyline prompt, type 0,0 and press Enter. 

4 At the Next point of polyline ( Undo ) prompt, type 5,0 and press Enter. 

5 At the Next point of polyline. Press Enter when done ( Undo ) prompt, type 5,5 and press 
Enter. 

6 At the Next point of polyline. Press Enter when done ( Close Undo ) prompt, type 0,5 and press 
Enter. 

7 At the Next point of polyline. Press Enter when done ( Close Undo ) prompt, click Close to close 
the polyline. 

 

 
Polyline 
Left click for Polyline. 
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Relative Coordinates 
Absolute coordinates can be slow and cumbersome, but they do work. Most of the time, relative 
coordinates are easier to use. Every time you select a point, Rhino saves that point as the last point. 
Relative coordinates are based on the last point entered, instead of on the origin (0,0,0) of the 
construction plane.  

Precede the x,y,z coordinates with a single R to enter relative coordinates. 

Exercise 12—Entering relative coordinates 
1 From the Curve menu, click Lines, and then click Polyline. 

2 At the Start of polyline prompt, type 8,0 and press Enter. 

3 At the Next point of polyline ( Undo ) prompt, type R5,0 and press Enter. 

These are absolute coordinates. 

4 At the Next point of polyline. Press Enter when done ( Undo ) prompt, type R0,5 and press 
Enter. 

These are relative coordinates. 

5 At the Next point of polyline. Press Enter when done ( Close Undo ) prompt, type R-5,0 and 
press Enter. 

6 At the Next point of polyline. Press Enter when done ( Close Undo ) prompt, click Close to close 
the polyline. 
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Polar Coordinates 
Polar coordinates specify a point that is a distance and direction away from 0,0 in the current 
construction plane. For example, if you want a point four units away from the construction plane 
origin, at a 45° angle clockwise from the construction plane x-axis, type 4<45, and press Enter. 
Relative polar coordinates are preceded by R; absolute polar coordinates are not. Instead of using x-, 
y-, and z-coordinates, enter relative polar coordinates like this: Rdistance<angle.  

Exercise 13—Entering polar coordinates 
1 From the Curve menu, click Lines, and then click Polyline. 

2 At the Start of polyline prompt, type 0,8 and press Enter. 

3 At the Next point of polyline ( Undo ) prompt, type R5<0 and press Enter. 

4 At the Next point of polyline. Press Enter when done ( Undo ) prompt, type R5<90 and press 
Enter. 

5 At the Next point of polyline. Press Enter when done ( Close Undo ) prompt, type R5<180 and 
press Enter. 

6 At the Next point of polyline. Press Enter when done ( Close Undo ) prompt, click Close to close 
the polyline. 
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Distance and Angle Constraint Entry  
Using distance constraint entry, you can specify a point by typing a distance and pressing Enter. Then 
as you move your cursor in any direction, the distance from the last point will be constrained. This is a 
good way to specify a line length quickly. 

Using angle constraint entry, you can specify an angle by typing < followed by a value and pressing 
Enter. The next point is constrained to lines at multiples of the angle relative to the x-axis you 
specified. 

Using the Shift key to toggle Ortho on and off: 

When Ortho is off you can hold the Shift key down to toggle it on. This method is an efficient way to 
draw perpendicular lines. In the following example, draw a line 5 units long using distance constraints. 

Exercise 14—Distance constraint entry 
1 From the Curve menu, click Lines, and then click Polyline. 

2 At the Start of polyline prompt, type 8,8 and press Enter. 

3 At the Next point of polyline ( Undo ) prompt, type 5 and press Enter. 

4 Hold the Shift key down and pick a point to the right. 

Ortho constrains the cursor to 0 degrees. 

 
Distance constraining value 5 

5 At the Next point of polyline. Press Enter when done ( Undo ) prompt, type 5 and press Enter. 

6 Hold the Shift key down and pick a point up. 

Ortho constrains the cursor to 90 degrees 

7 At the Next point of polyline. Press Enter when done ( Close Undo ) prompt, type 5 and press 
Enter. 

8 Hold the Shift key down and pick a point to the left. 

Ortho constrains the cursor to 180 degrees. 
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9 At the Next point of polyline. Press Enter when done ( Close Undo ) prompt, click Close to close 
the polyline. 

Exercise 15—Distance and angle constraint entry 
1 From the Curve menu, click Lines, and then click Polyline. 

2 At the Start of polyline prompt, type 16,5 and press Enter. 

3 At the Next point of polyline ( Undo ) prompt, type 5 and press Enter, then type <45 and 
press Enter. 

As you drag your cursor around the marker snaps to a distance of 5 and an angle of 45 degrees. 

4 Pick a point down and to the right. 

The angle constraint sets the angle. 

 
Angle constraint value 30 

5 At the Next point of polyline. Press Enter when done ( Undo ) prompt, type 5 and press Enter, 
then type <45 and press Enter. 

6 Pick a point up and to the right. 

The angle constraint sets the angle. 

7 At the Next point of polyline. Press Enter when done ( Close Undo ) prompt, type 5 and press 
Enter, then type <45 and press Enter. 

8 Pick a point up and to the left. 

The angle constraint sets the angle. 

9 At the Next point of polyline. Press Enter when done ( Close Undo ) prompt, click Close to close 
the polyline. 

10 Save your model. You will use this model for another exercise. 



 

Notes: 

Robert McNeel & Associates 51 

Exercise 16—Practice using distance and constraint entry 
1 Start a new model. Save as Arrow. 

 
2 Draw the arrow with a polyline, using a combination of absolute coordinates (x,y), relative 

coordinates (Rx,y), polar coordinates (Rdistance<angle), and distance constraint. 

Begin your model at -11,0. The following is an example of the command line input that you might 
use: 

Next point of polyline ( Undo ): r-2,-2 

Next point of polyline. Press Enter when done ( Undo ): r8,0 

Next point of polyline. Press Enter when done ( Close Undo ): r1,1 

Next point of polyline. Press Enter when done ( Close Undo ): r11<0 

Next point of polyline. Press Enter when done ( Close Undo ): r0,-1 

Next point of polyline. Press Enter when done ( Close Undo ): r6,2 

Next point of polyline. Press Enter when done ( Close Undo ): r-6,2 

Next point of polyline. Press Enter when done ( Close Undo ): r0,-1 

Next point of polyline. Press Enter when done ( Close Undo ): r11<180 

Next point of polyline. Press Enter when done ( Close Undo ): r-1,1 

Next point of polyline. Press Enter when done ( Close Undo ): r8<180 

Next point of polyline. Press Enter when done ( Close Undo ): c 

3 Save your model. 
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To make it 3-D: 

1 Select the polyline (1). 

2 From the Surface menu and click Revolve. 

3 Toggle Snap on. 

 
4 At the Start of revolve axis prompt, select the end of the arrow along the centerline (2). 
5 At the End of revolve axis prompt, select the other end of the arrow (3) along the centerline. 

6 In the Revolve Options dialog box, click OK. 

Your arrow is now a three-dimensional model. 

 
 

 
Revolve 
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Viewports 
Viewports are windows in the Rhino graphics area that show you a view of your model. To move and 
resize viewports, drag the viewport title or borders. The cursor moves along a construction plane, 
which is defined for each viewport. You can create new viewports, rename viewports, and use 
predefined viewport configurations. To activate a viewport click anywhere in the viewport and the title 
highlights. If you are in a command sequence, you simply have to move your cursor into a viewport to 
activate it. 
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Construction planes 
The construction plane is the guide used for modeling Rhino objects. Points you pick are always on the 
construction plane unless you use coordinate input, elevator mode, or object snaps. 

Each construction plane has its own axes, a grid, and an orientation relative to the world coordinate 
system. 

Default construction planes are provided with the default viewports. 

• The Top construction plane x- and y-axes align with the world x- and y-axes.  

• The Right construction plane x- and y-axes align with the world y- and z-axes.  

• The Front construction plane x- and y-axes align with the world x- and z-axes.  

• The Perspective viewport uses the Top construction plane. 

Each construction plane has a grid. The grid is a plane of perpendicular lines lying on the construction 
plane. On default grids, every fifth line is slightly thicker. The red line represents the construction 
plane x-axis. The green line represents the construction plane y-axis. The red and green lines meet at 
the construction plane origin. 

The red and green axes on the grid are the x- and y-axes of that viewport’s construction plane. The 
construction plane axes happen to be lined up with world axes when you first start Rhino, so it is 
confusing in the front and side viewports where the y-axis of the construction plane happens to be 
pointing up in the world z- direction. The icon in the left hand corner always shows world coordinates, 
which are different from the construction plane axes.  

Exercise 17—Modeling in 3-D space 
Rhino makes it easy to draw in 3-D space. You can draw on a different construction plane by simply 
moving your cursor into a different viewport. Another useful tool for modeling in 3-D space is 
elevator mode.  

In the following exercise we will draw in different viewports and use elevator mode to move some 
points in 3-D space. 
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You will use Snap and Ortho to draw in different viewports.  

1 Open the model Chair.3dm.  

 The model units are centimeters. 

2 Toggle Planar and Snap on. Toggle Ortho on as needed. 

3 From the Curve menu, click Lines, and then click Polyline. 

4 Move your cursor into the Front viewport. 

5 At the Start of polyline prompt, type 0,0 and press Enter. 

6 At the Next point of polyline prompt, use coordinate input to draw the first part of the chair 
frame. 

  
7 At the Next point of polyline prompt, move your cursor to the Right viewport to draw a 

horizontal line. 

 
8 At the Next point of polyline prompt, move your cursor to the Front viewport hold down the 

Ctrl key, and pick the point at the lower end of the diagonal line. 
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Holding the Ctrl key while clicking with the left mouse button activates elevator mode 

Elevator mode lets you pick points that are off the construction plane. Elevator mode requires 
two point picks to completely define the point. The first specifies the base point. The second 
specifies how far the final point is above or below the base point. 

After the base point is specified, the marker is constrained to a tracking line perpendicular to the 
construction plane that passes through the base point. 

Pick a second point to specify the coordinate of the desired point. You can pick a point with the 
mouse, or type a single number to specify the height above the construction plane. Positive 
numbers are above the construction plane; negative numbers are below. 

9 At the Next point of polyline prompt, release the Ctrl key, move your cursor to the Right 
viewport and adjust the point until it lines up with the other part of the chair, and pick. 

  
 

10 At the Next point of polyline prompt, continue drawing the rest of the chair frame. 

11 At the Next point of polyline prompt, on the next to the last segment you will have to use 
elevator mode again. 
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12 At the Next point of polyline prompt, click Close. 

 

We now want to draw along the chair back, so we will change the construction plane. 

To change the construction plane: 

1 On the Status Bar, click Osnap, and check End. 

2 From the View menu, click Set CPlane, then click 3 Points. 

3 At the CPlane origin prompt, move your cursor to the Perspective viewport, and pick the vertex 
(1) at the back of the chair. 

 
4 At the X axis direction prompt, pick the vertex (2) at the other side of the back. 

5 At the CPlane orientation prompt, pick the vertex (3) at the top of the chair. 

The construction plane is now aligned with the back of the chair. 

 

 
Set CPlane: 3 Points 
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6 Draw some lines on the new construction plane.  

 

To make it solid: 

1 Select the chair frame. 

2 From the Solid menu, click Pipe. 

3 At the Radius for closed pipe <1> ( Diameter ) prompt, type 3 and press Enter. 

The chair has a solid frame. 

 
4 Save the model. 

On your own: 

Try some variations and add some features. 

 

 
Pipe 
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Exercise 18—Practice using distance and angle constraints 
1 Start a new model using the Millimeters template. Save as V-Block. 

2 Double-click the viewport title in the Front viewport to maximize it. 

Create the following model in the front construction plane. 

3 Draw the object below using a combination of absolute coordinates (x,y), relative coordinates 
(rx,y), and relative polar coordinates (rdistance<angle). 

4 Start your model at 0,0 in the Front viewport.  

Try to create the model using a single polyline. 

 
5 Double-click the viewport title of the Front viewport to restore your views. 

6 Select the polyline. 

7 From the Solid menu, click Extrude Planar Curve. 

8 At the Extrusion distance <1> ( Direction Cap=Yes BothSides Tapered ) prompt, type 60 and 
press Enter. 

You can view the model as a three-dimensional object in the Perspective viewport. 

 
9 Save your model. 

 
Extrude Planar Curve 
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Object Snaps 
Object Snaps are tools for specifying points on existing objects. Use them for precision modeling and 
to get accurate data. Object snaps are often referred to as osnaps. In Rhino, reliable modeling and 
easy editing depends on objects actually meeting at specified points. Objects snaps give you precision 
you cannot get using the “eyeball” method 

To open the Osnap toolbar 

 Click the Osnap pane in the status bar.  

This toolbar controls persistent object snaps. Use persistent objects snaps to maintain an object snap 
through choosing several points without having to reactivate the object snap.  

When an object snap is active, moving the cursor near an eligible point on an object causes the 
marker to jump to that point and a tooltip to appear. 

Check a box to turn on the object snap. You can place the toolbar anywhere on your desktop.  

Command Button Description 

End 
 

End snaps to the end of a curve, surface edge or polyline segment. 

Near 
 

Near snaps to the nearest point on an existing curve or surface edge. 

Point 
 

Point snaps to a control point or point object. 

Mid 
 

Midpoint snaps to the midpoint of a curve or surface edge. 

Cen 
 

Center snaps to the center point of a curve. This works best with circles and arcs. With 
other curves, you will snap to the center points of circles based on the curvature at any 
given point. 

Int 
 

Intersection snaps to the intersection of two curves. 

Perp 
 

Perpendicular To snaps to the point on a curve that makes a perpendicular to the last 
selected point. Works only when you are selecting a series of points. 

Tan 
 

Tangent To snaps to the point on a curve that makes a tangent to the last selected 
point. This only works when you are selecting a series of points. 

Quad 
 

Quad snaps to the quadrant point. The quadrant point is the maximum or minimum 
direction on a curve in the x or y construction plane direction. 

Knot 
 

Knot snaps to knot points on curves or surface edges. 
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Command Button Description 
Project  Projects the snap point to the construction plane. 
Disable  Temporarily turns off running object snaps, retaining settings 

Exercise 19—Using object snaps 
1 Open the model Osnap.3dm. 

2 Toggle Snap and Ortho off. 

Using End and Midpoint object snaps: 

1 Click the Osnap pane on the status bar. 

 You can leave the Osnap toolbar displayed. 

 
Osnap bar with End and Mid on. 

2 Check End and Mid. 

You can check and clear individual object snaps to make modeling with precision easy. 

3 From the Curve menu, click Lines, and then click Polyline. 

4 At the Start of polyline prompt, move your cursor close to the end of the line at the lower left 
corner of the first square and pick when the marker snaps to the end of the line. 

5 Pick points to draw the polyline. 

The line starts exactly at that corner. 

 
6 At the Next point of polyline prompt, snap to the midpoint of the right vertical edge of the 

second square. 

The marker snaps to the midpoint of the line that the cursor touches, making the new line cross to 
the exact midpoint of that side.  

7 Pick to draw the polyline. 
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8 At the Next point of polyline prompt, snap to the end at the upper left corner of the first box. 

The marker snaps to the end of the line.  

9 Pick to draw the polyline, and press Enter. 

Using Near and Perpendicular to object snaps: 

1 In the Osnap toolbar check Near and Perp, clear End and Mid. 

2 From the Curve menu, click Lines, and then click Polyline. 

3 At the Start of polyline prompt, pick on the lower edge the circle at the top right. 

The marker snaps to the point on the circle nearest to where the cursor is positioned. 

 
4 At the Next point of polyline prompt, pick the top horizontal edge of the second square. 

The marker snaps to a point making a perpendicular to the previous point.  

5 Pick to draw the polyline, and press Enter. 

Using Intersection and Tangent to object snaps: 

1 In the Osnap toolbar check Int and Tan; clear Near and Perp. 

2 From the Curve menu, click Lines, and then click Polyline. 

3 At the Start of polyline prompt, pick the intersection where the diagonal line crosses the vertical 
line on the first square. 

The marker snaps to the intersection between the two lines. 
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4 At the Next point of polyline prompt, pick the top, left edge of the circle on the right. 

The marker snaps to a point tangent to the circle. 

5 Pick to draw the polyline segment, and press Enter. 

Using Center of object snap: 

1 In the Osnap toolbar check Cen, clear Int and Tan. 

2 From the Curve menu, click Lines, and then click Polyline. 

3 At the Start of polyline prompt, pick on the edge of a circle. 

The marker snaps to the center of the circle. 

 
4 At the Next point of polyline prompt, pick on the edge of the other circle. 

The marker snaps to the center of the circle. 

5 Pick to draw the polyline segment, and press Enter. 

Using Quadrant of object snap: 

1 In the Osnap toolbar check Quad, clear Cen. 

2 From the Curve menu, click Lines, and then click Polyline. 

3 At the Start of polyline prompt, pick a point on the top edge of the first circle. 

The marker snaps to the quadrant point of the circle. 

 
4 At the Next point of polyline prompt, pick the left edge of the circle. 

The marker snaps to the quadrant point of the circle. 
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5 At the Next point of polyline prompt, pick the bottom edge of the circle. 

6 At the Next point of polyline prompt, pick the right edge of the circle. 

7 At the Next point of polyline prompt, click Close. 

Analysis Commands 
Rhino provides analysis tools for finding lengths, angles, areas, distances, and the volume and 
centroid of solids. Additional commands let you analyze curve curvature, determine continuity 
between curves, and find unjoined edges. 

Command Description 

Distance Displays the distance between two points. 
Length Displays the length of an object. 
Angle Displays the angle between two lines. 
Radius Measures the radius of curvature of a curve, circle, or arc at the point where you pick the curve 

and displays it on the command line. 
EvaluatePt The Cartesian coordinates of the point, in both world and construction plane coordinates are 

displayed on the command line in x,y,z format. 

To find the distance between two points: 

1 From the Analyze menu, click Measure Distance. 

2 At the First point for distance prompt, pick the intersection where a diagonal line intersects a 
vertical line. 

3 At the Second point for distance prompt, pick the intersection where the other diagonal line 
intersects the same vertical line.  

 Use object snaps. 

  

 
Distance 
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4 Press F2 to display the information. 

CPlane angles and deltas: xy = 90 elevation = 0 dx = 0 dy = 3.077 dz = 0 

World angles and deltas:  xy = 90 elevation = 0 dx = 0 dy = 3.077 dz = 0 

Distance = 3.077 millimeters 

To find the length of a line: 

1 From the Analyze menu, click Measure Length. 

2 At the Select Curve to measure prompt, select the line between the centers of the circles. 

 
Length = 8.000 millimeters 

To measure the angle between two lines: 

1 From the Analyze menu, click Measure Angle. 

2 At the Start of line prompt, select a point that defines the start of an angle line. 

3 At the End of first line prompt, select a point that defines the end of an angle line. 

 Use object snaps as appropriate. 

 
4 At the Start of second line prompt, select a point that defines the beginning of the second 

angle line. 

 
Length 
 

 
Angle 
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5 At the End of second line prompt, select a point that defines the end of the second angle line. 

 
The angle displays on the command line in the following format: 

Angle is 21.7711 degrees 

To measure the radius of a circle: 

1 From the Analyze menu, click Measure Radius. 

2 At the Select point on curve for radius measurement prompt, select one of the circles. 

This also measures a radius on a curve.  

 
The radius displays on the command line in the following format: 

Radius at pick point is 2.5 

To evaluate a point: 

1 From the Analyze menu, click Analyze Point. 

2 At the Point to evaluate prompt, snap to the end point of one of the squares. 

 

 
Radius 
 

 
Point 
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The x,y,z point is displayed for the world coordinate plane and the current construction plane. 

Point in world coordinates = 8.000,5.000,0  CPlane coordinates = 8.000,5.000,0 

Drawing Circles 
You can create circles using a center point and radius, center point and a diameter, two points on the 
diameter, three points on the circumference, and tangent points to two coplanar curves and a radius.  

Button Command Description 

 

Circle Draw a circle using the center and radius. 

 

Circle 3Point Draw a circle through three points on its circumference 

 

Circle Diameter Draw a circle using two diameter points. 

 

Circle Tangent Draw a circle tangent to two or three curves. 

 

Circle AroundCurve Draw a circle perpendicular to a curve at the chosen point. 

Circle options  

Option Description 
Deformable Draws an approximation of a circle with a defined number of control points.. 
Vertical Draw a circle perpendicular to the construction plane. 

Exercise 20—Drawing circles 

To draw a center, radius circle: 

1 From the Curve menu, click Circle. 

2 At the Center of circle ( Deformable Vertical 2Point 3Point Tangent AroundCurve ) prompt, type 
20,10 and press Enter. 

3 At the Radius <1> ( Diameter ) prompt, type 3 and press Enter. 

A circle is created. 

 
Circle 
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To draw a center, diameter circle: 

1 From the Curve menu, click Circle. 

2 At the Center of circle ( Deformable Vertical 2Point 3Point Tangent AroundCurve ) prompt, type 
20,3 and press Enter. 

3 At the Radius <3> ( Diameter ) prompt, click Diameter. 

4 At the Diameter <6.00> ( Radius ) prompt, type 5 and press Enter. 

A circle is created that is based on a center point and a diameter. The Diameter option will be the 
default until you change it. 

 

To draw a 3-point circle: 

1 From the Curve menu, click Circle. 

2 At the Center of circle ( Deformable Vertical 2Point 3Point Tangent AroundCurve ) prompt, click 
3Point. 

3 At the First point on circle prompt, snap to an End on one of the squares. 

4 At the Second point on circle prompt, snap to another vertex on the same square. 

5 At the Third point on circle prompt, snap to a third vertex on the other square. 

A circle is created with a circumference that intersects the three ends you picked. 

 

 
Circle 3Pt 
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To draw a diameter circle: 

1 From the Curve menu, click Circle. 

2 At the Center of circle ( Deformable Vertical 2Point 3Point Tangent AroundCurve ) prompt, click 
2Point. 

3 At the First point on circle prompt, pick a point on the screen. 

4 At the Second point on circle prompt, type 3 and press Enter, then turn Ortho on and pick to 
the right. 

A circle is created with the two points you picked as the diameter, and the diameter was 
constrained to a value of 3. 

 

To draw a tangent, tangent, radius circle: 

1 From the Curve menu, click Circle. 

2 At the Center of circle ( Deformable Vertical 2Point 3Point Tangent AroundCurve ) prompt, click 
Tangent. 

3 At the First point ( Point ) prompt, select the circle you just created near the top edge. 

4 At the Second point or radius <5> ( Point FromFirstPoint ) prompt, type 2 and press Enter. 

5 At the Second point or radius <2> ( Point FromFirstPoint ) prompt, pick the other circle.  

A circle is created that is tangent to the two circles you selected with a radius of 2.  

 

 
Circle Diameter 
 

 
Circle Tangent, Tangent, Radius 
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To draw a tangent, tangent, tangent circle: 

1 From the Curve menu, click Circle. 

2 At the Center of circle ( Deformable Vertical 2Point 3Point Tangent AroundCurve ) prompt, click 
Tangent. 

3 At the First point ( Point ) prompt, select a circle you created. 

4 At the Second point or radius <2> ( Point FromFirstPoint ) prompt, select another circle or line. 

5 At the Third point ( Point ) prompt, pick another piece of geometry.  

A circle is created that is tangent to the three pieces of geometry that you selected. 

 

To draw a circle vertical to the construction plane: 

1 From the Curve menu, click Circle. 

2 At the Center of circle ( Deformable Vertical 2Point 3Point Tangent AroundCurve ) prompt, click 
Vertical. 

3 At the Center of circle ( 2Point ) prompt, pick a point. 

4 At the Radius <4> ( Diameter ) prompt, type 3 and press Enter. 

The circle is drawn perpendicular to the construction plane. You will be able to see it in the one of 
the other viewports. 

  

 
Circle Tangent to 3 Curves 
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To draw a circle around a curve: 

1 From the Curve menu, click Circle. 

2 At the Center of circle ( Deformable Vertical 2Point 3Point Tangent AroundCurve ) prompt, click 
AroundCurve. 

3 At the Center of circle prompt, pick a point. 

4 At the Radius <2> ( Radius ) prompt, click Radius. 

5 At the Radius <2> ( Diameter ) prompt, type 1 and press Enter. 

The circle is drawn perpendicular to the curve at the point you picked. You will be able to see it in 
the Perspective viewport. 
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Exercise 21—Practice drawing circles 
1 Start a new model. Save as Circles. 

2 From the Edit menu, click Layers, and then click Edit. 

3 In the Layers window, click the New icon three times. 

4 Rename the new layers Box, Line, Circle. 

5 Change the color of the Box layer to green, Line to cyan, and Circle to red. 

6 Draw the lines and circles on the appropriate layers.  

Use Line Segments for the box and Single Line for the centerlines. You will use several of the 
circle options and object snaps to complete this model. 

Circle

Circle TTR

Circle 2P All circles R2.0

15.00

7.50

20.00
10.00

 

To make it 3-D: 

1 Select the lines that form the rectangle. 

2 From the Surface menu, click Extrude. 

3 At the Distance ( Direction BothSides=No Cap=No Mode=Straight ) prompt, click Cap.  

4 At the Distance ( Direction BothSides=No Cap=Yes Mode=Straight ) prompt, type 2 and press 
Enter.  

The rectangle generates a box. 
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5 Select the circles. 

6 From the Surface menu, click Extrude. 

7 At the Distance ( Direction BothSides=No Cap=Yes Mode=Straight ) prompt, type -6 and press 
Enter. 

8 At the Distance ( Direction BothSides=No Cap=Yes Mode=Straight ) prompt, drag the mouse in 
the Front view and click. 

The circles generate cylinders. 

  

Exercise 22—Using circle-related object snaps 
1 Start a new model. Save as Link. 

2 Complete the model as shown. 

3 Draw the three large circles first. 

4 Draw the small holes next.  

Use object snaps to snap to the centers of the large circles. 
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To draw the tangent lines: 

1 From the Curve menu, click Lines, and then click Single Line. 

2 At the Start of line ( Normal Angled Vertical FourPoint Bisector Perpendicular Tangent Extend 
BothSides ) prompt, click Tangent. 

3 At the Start of line prompt, pick on the edge of one of the circles near where you want the 
tangent line to attach. 

4 At the End of line prompt, pick on the edge of another circle it will find the tangent points for 
you. 

 
5 Continue to use this command to complete the model. 

6 Save your model. 

 
Line Tangent to 2 Curves 
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Drawing Arcs 
You can create arcs using various points on the arc and construction geometry. 

You can continue an existing curve with an arc to an existing curve to a point or by an angle. 

Button Command Description 

  

Arc Draw an arc from the center, start, and angle. 

 

  

Arc 3Points Draw an arc from three points. 

  

Arc Start, End, Direction Draw an arc from start point, end point, and the direction from the 
start point. The direction can be entered after the start point is 
entered or after the end point is entered. 

  

Arc Tangent, Tangent, 
ThroughPoint 

Creates an arc from tangents and radius. 

 

Arc Start End Radius Creates an arc from start point, end point, and radius. 

 

Convert Output=arcs Converts a curve to arc segments that are joined together. 

 

CurveThroughPt 
Convert Output=arcs 

Creates an interpolated curve through selected points and then 
converts the curve to arc segments. 

Arc options  

Option Description 
Deformable Creates uniform cubic splines. You can enter the number of control points.. 
Extension Extend a curve with an arc. 
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Exercise 23—Practice drawing arcs (1) 
 Open the model Arc1.3dm. 

ARC: EXTENSION

ARC: EXTENSION

 

To draw a center, start, end or angle arc: 

1 From the Curve menu, click Arc. 

2 At the Center of arc ( Deformable StartPoint Tangent Extension ) prompt, snap to the center of 
the circle at the lower left. 

3 At the Start or arc prompt, snap to the end of the line. 

4 At the End of arc prompt, snap to the end of the other line. 

 

To draw a start, end, direction arc: 

1 From the Curve menu, click Arc, and then click Start, End, Direction. 

2 At the Start of arc ( Deformable ) prompt, pick a start point. 

3 At the End of arc ( Direction ThroughPoint ) prompt, pick an end point. 

 
Arc 
 

 
Direction Arc 
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4 At the Direction at start prompt, toggle Ortho on and drag straight up for the tangent at the 
start point and pick. 

 
5 Make another Direction Arc at the upper right. 

 

To add more arc segments: 

1 From the Curve menu, click Arc. 

2 At the Center of arc ( Deformable StartPoint Tangent Extension ) prompt, type E and press 
Enter. 

3 At the Select curve near end prompt, pick near the end of the arc you just made. 

4 At the End of arc ( Center ) prompt, type and press Enter. 

5 At the End of arc ( Center ) prompt, with Ortho on pick a point below the first point. 

The arc will be tangent to the curve you chose. 

 
6 From the Curve menu, click Arc. 
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7 At the Center of arc (Deformable StartPoint Tangent Extension ) prompt, type E and press 
Enter. 

8 At the Select curve near end prompt, pick near the end of the arc you just made. 

9 At the End of arc ( Center ) prompt, snap to the end of the line. 

 

To draw a tangent, tangent, radius arc: 

1 From the Curve menu, click Arc, and then click Tangent, Tangent, Radius. 

2 At the First tangent curve ( Point ) prompt, pick the lower right side of the top circle. 

3 At the Second tangent curve or radius <1> ( Point FromFirstPoint ) prompt, type 3 and press 
Enter. 

4 At the Second tangent curve or radius <3> ( Point FromFirstPoint ) prompt, pick the upper 
right side of the lower circle. 

5 At the Choose arc prompt, move your cursor and pick when the correct arc is displayed. 

 
6 From the Curve menu, click Arc, and then click Tangent, Tangent, Radius. 

7 At the First tangent curve ( Point ) prompt, pick the upper left side of the top circle. 

8 At the Second tangent curve or radius <1> ( Point FromFirstPoint ) prompt, type 6 and press 
Enter. 

9 At the Second tangent curve or radius <6> ( Point FromFirstPoint ) prompt, pick the lower left 
side of the lower circle. 

 
Arc Tangent, Tangent, Radius 
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10 At the Choose arc prompt, move your cursor and pick when the correct arc is displayed. 

 
11 Save your model. 

Exercise 24—Practice drawing arcs (2) 
Draw construction centerlines first: use their intersection point to draw your arcs and circles. 

1 Start a new model. Save as Arc2. 

2 Create this model using object snaps and the Line, Circle, and Arc commands. 
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To make it solid: 

1 Select the curves. 

2 From the Surface menu, click Extrude. 

3 At the Distance ( Direction BothSides=No Cap=No Mode=Straight ) prompt, click Cap.  

4 At the Distance ( Direction BothSides=No Cap=Yes Mode=Straight ) prompt, type 1 and press 
Enter.  

The curves have been extruded and capped. 

 

Drawing Ellipses and Polygons  
You can draw ellipses from the center or by the ends. You can draw polygons from a center point or 
an edge. You can draw a rectangle from diagonal corners or by choosing three points. 

Ellipses 
Button Command Description 

  

Ellipse Draw an ellipse by specifying the center point and axis ends. 

 

Ellipse Diameter Draw an ellipse by specifying the axis ends. 

 

Ellipse FromFoci Draw the ellipse from the focus points 

 

AroundCurve Draw an ellipse whose axis is perpendicular to a curve. 
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Polygons 
Button Command Description 

  

Polygon Creates a polygon from its center and radius. 

 

Polygon Edge Draw a polygon by specifying the ends of one edge. 

 

Polygon Star Draw a star from a polygon. 

Polygon options 

Option Description 
NumSides Specify the number of sides for the polygon. 
Circumscribed Draw a polygon that is circumscribed about a radius. The default is to draw a polygon that is 

inscribed in a specified radius. 

Rectangles 
Button Command Description 

  

Rectangle Draw a rectangle using opposite corners. 

  

Rectangle Center Draw a rectangle from center and a corner. 

 

3Point Draw a rectangle through three points. 

 

Vertical Draw a rectangle that is perpendicular to the construction plane. 

 

Rounded Create a rectangle with rounded corners (arc or conic). 
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Exercise 25—Practice drawing ellipses and polygons 
Start a new model. Save as Toy. 

5.0

8.0

20.0
19.0
18.0
14.0

RADIUS 1.5 FOR
ALL POLYGONS

10.0

10.0 9.0 8.0

R0.5R1.0

 

To draw a rectangle from diagonal corners: 

1 From the Curve menu, click Rectangle. 

2 At the First corner of rectangle ( 3Point Vertical Center Rounded ) prompt, type -10,-5 and 
press Enter. 

3 At the Other corner or length prompt, type 20 and press Enter. 

4 At the Width prompt, type 10 and press Enter. 

Draw rectangles from a center point with a length and width, and rounded corners: 

1 From the Curve menu, click Rectangle, and then click Center, Corner. 

2 At the Center of rectangle ( Rounded ) prompt, type R, and press Enter to give the rectangle 
rounded corners. 

3 At the Center of rectangle prompt, type 0,0 and press Enter. 

4 At the Corner or length prompt, type 19 and press Enter. 

5 At the Width prompt, type 9 and press Enter. 

 
Rectangle 
 

 
Centered Rectangle 
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6 At the Rho or point for conic corner to pass through <1> ( Corner=Arc ) prompt type 1, and 
press Enter. 

If you are creating a rounded rectangle, select a point in the corner to set its curvature. 

Or, type C, and press Enter to toggle from circular rounded corners to conic rounded corners. 

7 Repeat these steps for a second rounded rectangle with a length of 18 and a width of 8 with .5 
radius corners. 

To draw an ellipse from its center and axis ends: 

1 From the Curve menu, click Ellipse, and then click From Center. 

2 At the Center of ellipse ( Corner Diameter FromFoci AroundCurve ) prompt, type 0,0 and press 
Enter. 

3 At the End of First axis ( Corner ) prompt, type 4, and press Enter. 

4 At the End of First axis ( Corner ) prompt, toggle Ortho on and pick to the right. 

5 At the End of Second axis prompt, type 3, and press Enter. 

6 At the End of second axis prompt, pick a point. 

To draw a polygon from its center and radius: 

1 From the Curve menu, click Polygon, and then click Center, Radius. 

2 At the Center of inscribed polygon ( NumSides=4 Circumscribed Edge Star Vertical 
AroundCurve ) prompt, type 3 and press enter to change the number of sides for the polygon. 

3 At the Center of inscribed polygon ( NumSides=3 Circumscribed Edge Star Vertical 
AroundCurve ) prompt, type -7,-2 and press enter to locate the center point for the polygon. 

4 At the Corner of polygon ( NumSides=3 ) prompt, type 1.5, and press Enter. 

5 At the Corner of polygon ( NumSides=3 ) prompt, pick a point to orient the polygon. 

6 Continue drawing the rest of the polygons. Use the same radius for each one. 

 
Ellipse 
 

 
Polygon 
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To make the rounded rectangles solid: 

1 Select the larger rounded rectangle. 

2 From the Surface menu, click Extrude. 

3 At the Distance ( Direction BothSides=No Cap=No Mode=Straight ) prompt, click Cap.  

4 At the Distance … prompt, drag it down to set the thickness and click. 

 
5 Select the smaller rounded rectangle. 

6 From the Surface menu, click Extrude. 

7 At the Distance ( Direction BothSides=No Cap=Yes Mode=Straight ) prompt, click Cap.  

8 At the Distance … prompt, drag it down until it is slightly above the previous solid and click. 

  

To make the rounded rectangle hollow: 

1 Select the outer rounded rectangle. 

2 From the Solid menu, click Difference. 
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3 At the Select second set of surfaces or polysurfaces. … prompt, select inner rounded 
rectangle, and press Enter. 

 

To make the rectangle solid: 

1 Select the  rectangle. 

2 From the Surface menu, click Extrude. 

3 At the Distance ( Direction BothSides=No Cap=Yes Mode=Straight ) prompt, click Cap.  

4 At the Distance … prompt, drag it up to set the thickness and click. 

  

To make the ellipse solid: 

1 Select the ellipse. 

2 From the Surface menu, click Extrude. 

3 At the Distance ( Direction BothSides=No Cap= Yes Mode=Straight ) prompt, click Cap. 

4 At the Distance ( Direction BothSides=No Cap= Yes Mode=Straight ) prompt, click Bothsides. 
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5 At the Distance … prompt, pick to set the thickness. 

 

To cut the ellipse solid from the rectangle: 

1 Select the solid rectangles. 

2 From the Solid menu, click Difference. 

3 At the Select second set of surfaces or polysurfaces. … prompt, select the solid ellipse, and 
press Enter. 

 

To extrude the polygons: 

1 Select the polygons. 

2 From the Surface menu, click Extrude. 

3 At the Distance ( Direction BothSides=No Cap=No Mode=Straight ) prompt, click Cap. 

4 At the Distance ( Direction BothSides=No Cap=Yes Mode=Straight ) prompt, click Bothsides. 

5 At the Distance … prompt, pick to set the thickness. 

To cut holes with the solid polygons: 

1 Select the solid rectangles. 

2 From the Solid menu, click Difference. 

3 At the Select second set of surfaces or polysurfaces. … ( DeleteInput=Yes ) prompt, type D 
and press Enter. 

 
Boolean Difference 
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4 At the Select second set of surfaces or polysurfaces. … ( DeleteInput=No ) prompts, select 
the solid polygons and press Enter. 

Holes will be cut, but the objects will remain. 

 

Modeling Free-Form Curves 
The use of free-form curves allows more flexibility to create complex shapes.  

Button Command Description 

  

Curve Curve by control points draws a curve from specified control points. Control 
points mostly do not lie on the curve, but they determine its shape. 

  

InterpCrv Interpolated curve creates a curve going through specified interpolate points. 
These points lie on the curve and determine its curvature. 

 

Conic Draw a conic curve, which is part of an ellipse, parabola, or hyperbola. 

 

Option Description 
Undo Allows you to back up one point. 
Close Makes a closed curve. 
Sharp If Yes, makes a closed curve with a sharp point. 
Degree Allows you to set the degree of the curve. 

Exercise 26—Practice drawing curves (1) 
1 Open the model Curve.3dm. 

In this exercise, you will learn how to make a curve by control points, an interpolated curve, and a 
conic curve to compare the differences between the three methods. 

A common method to create with free-form curves is to draw lines that are accurately measured 
to use as guidelines. In this exercise the guidelines have been created for you. 
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2 In the Osnap toolbar, check End and Near, clear all others. 

If you click End with your right mouse, it will clear all the others. 

3 Toggle Ortho and Snap off. 

To draw a curve by control points: 

1 From the Curve menu, click Free-form, and then click Control Points. 

2 At the Start of curve ( Degree=3 ) prompt, snap to the end point of the polyline guideline. 

3 At the Next point ( Degree=3 Undo ) prompt, snap on the polyline guideline using the Near 
object snap. 

4 At the Next point ( Degree=3 Undo ) prompt, snap on the polyline guideline using the Near 
object snap until you get to the end. 

5 At the Next point ( Degree=3 Close Sharp=Yes Undo) prompt, press Enter. 

A free-form curve is drawn. The control points, while on the guideline, were not on the curve itself 
except at the two ends.  

Control points control the curvature of the curve, but the curve is usually not on them. 

 

To draw a curve interpolate through points: 

1 Change to the Interpolated Curve layer. 

2 From the Curve menu, click Free-form, and then click Interpolate Points. 

3 At the Start of curve ( Degree=3 Knots=SqrtChord StartTangent ) prompt, snap to the end point 
of the polyline guideline. 

4 At the Next point of curve ( Degree=3 Knots=SqrtChord EndTangent Undo ) prompt, snap on 
the polyline guideline using the Near object snap. 

5 At the Next point of curve ( Degree=3 Knots=SqrtChord EndTangent Undo ) prompt, continue to 
snap to the guideline until you get to the end. 

 
Curve 
 

 
Interpolated Curve 
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6 At the Next point of curve ( Degree=3 Knots=SqrtChord EndTangent Close Sharp=Yes Undo ) 
prompt, press Enter. 

A free-form curve is created from specified interpolate points. These points lie on the curve and 
determine its curvature. 

Note how difficult it is to make the curve follow the guideline exactly.  

 

To draw a conic curve: 

1 Change to the Conic layer. 

2 From the Curve menu, click Conic. 

3 At the Start of conic ( Tangent Perpendicular ) prompt, snap to the point (1) at the lower left. 

4 At the End of conic ( Apex Tangent Perpendicular ) prompt, snap to the point (2) above and to 
the right from the previous point.  

5 At the Apex prompt, snap to the point (3) in between the previous points. 

6 At the Curvature point or rho prompt, pick a point for the desired curvature.  

 

 
Conic 
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Modeling Helix and Spiral 
The use of free-form curves allows more flexibility to create complex shapes. If you need to control 
precision, you can make construction lines that define your overall parameters. 

Button Command Description 

 

Helix Draw a helix. User can specify a radius, the number of turns, the length and 
direction of the axis. 

 

Spiral Draw a spiral. User can specify two radii, the number of turns, the length and 
direction of the axis. 

 

Option Description 
Vertical The helix or spiral axis will be perpendicular to the construction plane in the active viewport. 
AroundCurve Select a curve for the helix or spiral to wind around to create "phone cord" shapes. 
Flat Lets you draw a planar spiral. 
Mode Determines whether the number of turns or the distance between turns is used to create the helix 

or spiral 
 Turns Allows you to set the number of turns along the axis. 
 Pitch Allows you to set the distance between turns along the axis. 
ReverseTwist Allows you to reverse the twist direction of the helix or spiral. 

To draw a helix 

1 Change to the Helix layer. 

2 Turn on the End and Point object snap. 

3 From the Curve menu, click Helix. 

4 At the Start of axis ( Vertical AroundCurve ) prompt, snap to the end of the vertical line (1) in 
the Perspective viewport..  

5 At the End of axis prompt, snap to the end of the vertical line (2) in the Perspective viewport. 

 
Helix 
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6 At the Radius and start point <1.000> ( Diameter Mode=Turns Turns=10 Pitch=1 
ReverseTwist=No ) prompt, pick the point (3) to the right of the axis line. 

A helix with 10 turns and a radius of 2.5 is created. 

  

To draw a spiral: 

1 Change to the Spiral layer.  

2 From the Curve menu, click Spiral. 

3 At the Start of axis ( Flat Vertical AroundCurve ) prompt, snap to the end of the other vertical 
line (1) in the Perspective viewport. 

4 At the End of axis prompt, snap to the other end of the same line (2). 

5 At the First radius and start point <1> ( Diameter Mode=Turns Turns=10 Pitch=1 
ReverseTwist=No ) prompt, click Mode. 

6 At the First radius and start point <0.735> ( Diameter Mode=Pitch Turns=10 Pitch=1 
ReverseTwist=No ) prompt, click Pitch 

7 At the Pitch <1> prompt, type 4 and press Enter. 

8 At the First radius and start point <1> ( Diameter Mode=Pitch Turns=10 Pitch=4 
ReverseTwist=No ) prompt, click ReverseTwist. 

9 At the First radius and start point <1> ( Diameter Mode=Pitch Turns=10 Pitch=4 
ReverseTwist=Yes ) prompt, snap the point (3) for the radius of the base of the spiral. 

10 At the Second radius <0> ( Diameter Mode=Pitch Turns=10 Pitch=4 ReverseTwist=Yes ) 
prompt, snap to the other point (4) for the ending radius. 

A spiral is created with a reverse twist and a pitch of 4. 

 

 
Spiral 
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Exercise 27—Drawing free-form curves 
In the following exercise we will draw the guidelines and free-form curves for a toy screwdriver.  

 
1 Start a new model. Save as Screwdriver. 

2 Create Construction and Curve layers.  

Make them different colors. 

To create the construction lines: 

1 Change to the Construction layer. 
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2 Draw a polyline using the dimensions above for the guideline. 

To create the curve by control points: 

1 Change to the Curve layer. 

2 Use the Curve command to draw the shape for the toy screwdriver. 

 
3 Save your model. 
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To make it solid: 

1 Toggle Snap and Ortho on. 

2 From the Surface menu and click Revolve. 

3 At the Select curve to revolve prompt, select the curve. 

 
4 At the Start of revolve axis prompt, snap to the end of the curve. 
5 At the End of revolve axis prompt, snap to the other end of the curve. 

6 In the Revolve Options dialog box, click OK. 

Your model is now a three-dimensional surface. 

 
 

 
Revolve 
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5  

 

 

 
 
Editing Objects 

Once you create objects, you can move and edit them to produce complex and detailed variations.  

Fillet  
Fillet connects two lines, arcs, circles, or curves extending or trimming them to touch or to join with a 
circular arc.  

Option Description 
Radius Sets the fillet radius. A radius of 0 extends or trims the curves to a corner, but does not create a 

fillet. 
Join Yes joins the fillet to the curves. No does not join the fillet to the curves. 
Trim Yes trims the curves to the fillet arc. No does not trim the curves. 

Exercise 28—Fillet 
 Open the model Fillet.3dm. 

To fillet lines at a zero radius: 

1 From the Curve menu, click Fillet. 

2 At the Select first curve to fillet ( Radius=0 Join=No Trim=Yes ) prompt, click Radius to 
change the radius. 

3 At the Fillet radius <1> prompt, type 0, and press Enter. 

This Radius option remains the default until you change it. 

4 At the Select first curve to fillet ( Radius=0 Join=No Trim=Yes ) prompt, select an outer 
vertical line. 

 
Fillet 
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5 At the Select second curve to fillet ( Radius=0 Join=No Trim=Yes ) prompt, select an adjacent 
horizontal line. 

The ends of the lines are trimmed to a corner. 

 
6 Press Enter to repeat the command. 

7 Fillet the other corners, as shown. 

 

To fillet lines using an arc: 

1 From the Curve menu, click Fillet. 

2 At the Select first curve to fillet ( Radius=0 Join=No Trim=Yes ) prompt, type 2 and press 
Enter to change the radius. 

This is another method to change the radius. 

3 At the Select first curve to fillet ( Radius=2 Join=No Trim=Yes ) prompt, click Join to change 
the Join option to Yes. 

This option joins the curves as they are filleted. 

4 At the Select first curve to fillet ( Radius=2 Join=Yes Trim=Yes ) prompt, select an outer 
vertical line. 

5 At the Select second curve to fillet ( Radius=2 Join=Yes Trim=Yes ) prompt, select an adjacent 
horizontal line. 

The ends of the lines are trimmed to a radius. 

6 Press Enter to repeat the command. 

Remember to pick on the part of 
the line that you want to keep. 
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7 Fillet the other corners as shown. 

 
8 Press Enter to repeat the command. 

9 At the Select first curve to fillet ( Radius=2 Join=Yes Trim=Yes ) prompt, type 1 and press 
Enter. 

This radius will be used for the smaller object. 

10 At the Select first curve to fillet ( Radius=1 Join=Yes Trim=Yes ) prompt, select an outer 
vertical line. 

11 At the Select second curve to fillet ( Radius=1 Join=Yes Trim=Yes ) prompt, select an adjacent 
horizontal line. 

12 Fillet the other corners as shown. 

 

To fillet circles: 

1 From the Curve menu, click Fillet. 

2 At the Select first curve to fillet ( Radius=1 Join=Yes Trim=Yes ) prompt, type 3 and press 
Enter. 

3 At the Select first curve to fillet ( Radius=3 Join=Yes Trim=Yes ) prompt, click Trim. 

This also disables the Join option. 

4 At the Select first curve to fillet ( Radius=3 Trim=No ) prompt, select the right edge of a circle. 

5 At the Select second curve to fillet ( Radius=3 Trim=No ) prompt, select the right edge of the 
other circle. 
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6 Repeat the command for the left side of the circles. 

 

To fillet and join arcs and lines: 

1 From the Curve menu, click Fillet. 

2 At the Select first curve to fillet ( Radius=3 Trim=No ) prompt, click Trim. 

3 At the Select first curve to fillet ( Radius=3 Join=Yes Trim=Yes ) prompt, select one of the arcs 
in the middle of the viewport. 

4 At the Select second curve to fillet ( Radius=3 Join=Yes Trim=Yes ) prompt, select the other 
arc in the middle of the viewport. 

 
5 Repeat this procedure for the arc and the line at the bottom left. 

To join the filleted objects: 

1 Select the objects at the top with a window. 

 

 
Join 
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2 From the Edit menu, click Join. 

The objects are joined together. Curves join only if they touch. 

To make a lofted surface: 

1 Change to the Surfaces layer. 

2 Select the two squares in the upper left part of the Top viewport. 

3 Change to the Perspective viewport. 

4 From the Surface menu, click Loft. 

The two squares show a seam direction arrow. They point the same direction. 

 
5 At the Select seam point to adjust, press Enter when done ( FlipDirection Automatic 

Natural ) prompt, press Enter. 

6 In the Loft Options dialog box, click OK. 

A surface is generated between the two closed polylines. 

 

 

The lines in this model are at two 
different elevations. You are 
going to connect the lines at 
different elevations with a 
surface. 

 
Loft 
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7 Repeat the procedure for the rounded squares. 

8 In the Loft Options dialog box, click OK. 

 
9 Save your model. 

Chamfer  
Chamfer connects two curves by extending or trimming them to intersect or to join with a beveled 
line. Chamfer works on convergent or intersecting curves.  

Option Description 
Distances The first chamfer distance specifies the distance from the chamfer end on the first curve to the 

point where the two curves would intersect. The second chamfer distance specifies the distance 
of the chamfer end on the second curve to the intersection point. 
A chamfer distance of 0 trims or extends that curve to the intersection point. If the chamfer 
distance is non-zero, a chamfer line is created that far from the intersection, and the curve is 
extended to the chamfer line. If you enter 0 for both distances, the curves are trimmed or 
extended to their intersection, but no chamfer line is created. 

Exercise 29—Chamfer 
 Open the model Chamfer.3dm. 

To chamfer lines: 

1 From the Curve menu, click Chamfer. 

2 At the Select first curve to chamfer ( Distances=1,1 Join=No Trim=Yes ) prompt, type 1,1, and 
press Enter, to set the distances. 

3 At the Select First Curve to chamfer ( Distances=1,1 Join=No Trim=Yes ) prompt, select one of 
the inner vertical lines. 

 
Chamfer 
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4 At the Select Second Curve to chamfer ( Distances=1,1 Join=No Trim=Yes ) prompt, select an 
adjacent horizontal line. 

   
5 Continue creating chamfers on all of the corners as shown. 

6 Press Enter to repeat the command. 

7 At the Select First Curve to chamfer ( Distances=1,1 Join=No Trim=Yes ) prompt, type 3,2 and 
press Enter. 

8 At the Select First Curve to chamfer ( Distances=3,2 Join=No Trim=Yes ) prompt, select one of 
the outer horizontal lines. 

9 At the Select Second Curve to chamfer ( Distances=3,2 Join=No Trim=Yes ) prompt, select an 
adjacent vertical line. 

The first value is the distance along the first curve selected, the second value is the distance along 
the second line selected. 

  
10 Continue creating chamfers on all of the corners as shown. 

To join the chamfered objects: 

1 From the Edit menu, click Select, and then click Curves. 

2 From the Edit menu, click Join. 

The curves have been joined together into closed polylines. 

To turn the curves into surfaces: 

1 Change to the Surfaces layer. 

 
Select Curves 
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2 From the Edit menu, click Select, and then click Curves. 

3 From the Surface menu, click Loft. 

4 At the Select seam point to adjust, press Enter when done ( FlipDirection Automatic 
Natural ) prompt, press Enter. 

5 In the Loft Options dialog box, click OK. 

A surface is generated between the two chamfered rectangles. 

 

 

6 Save your model. 

Exercise 30—Practice with Fillet and Chamfer 

 



 

Notes: 

Robert McNeel & Associates 103 

1 Open the model Filletex.3dm. 

 
2 Use Fillet and Chamfer to edit the drawing as shown. 

All fillets and rounds use a radius of 0.5 units. 

 

To make it solid: 

1 From the Edit menu, click Select, and then click Curves. 

2 From the Solid menu, click Extrude Planar Curves. 

3 At the Extrusion distance ( Direction Cap=Yes BothSides Tapered ) prompt, type .5 and press 
Enter. 
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Move 
Use Move to move objects without changing orientation or size.  

Option Description 
Vertical Moves the selected objects vertical to the current construction plane. 

Exercise 31—Move 
1 Open the model Move.3dm. 

 
2 Turn off both Ortho and Snap so you can move objects freely. 

3 Turn Cen object snap on. 

To move using object snaps for placement: 

1 Select the small circle at the bottom left side of the Top viewport. 

2 From the Transform menu, click Move. 

3 At the Point to move from ( Vertical ) prompt, snap to the center of the small circle. 

4 At the Point to move to prompt, snap to the center of the arc at the lower left of the object. 

  

To move using absolute coordinates: 

1 From the Edit menu, click Select, and then click Curves. 

2 From the Transform menu, click Move. 

 
Move 
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3 At the Point to move from ( Vertical ) prompt, snap to the end of the line at the lower part of 
the object. 

4 At the Point to move to prompt, type 0,0 and press Enter. 

The end of the line is exactly at point 0,0 in the Top viewport. 

 

To move using relative coordinates: 

1 Select the large slotted circle in the middle of the object. 

You will move the slotted circle relative to the part. 

2 From the Transform menu, click Move. 

3 At the Point to move from ( Vertical ) prompt, pick any point in the Top viewport. 

It is usually better if you pick near the object you are going to move. 

4 At the Point to move to prompt, type r0,-.25 and press Enter. 

The circle is moved down .25 units. 
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Copy 
Copy duplicates selected objects and places them in a new location. The command can repeat to 
create more than one copy in the same command sequence. 

Option Description 
Vertical Copies the selected objects vertical to the current construction plane. 
InPlace Duplicates the object at the current location. 

Exercise 32—Copy 

To copy using object snaps for placement: 

1 Select the small circle at the lower left of the object. 

2 From the Transform menu, click Copy. 

3 At the Point to copy from ( Vertical InPlace ) prompt, snap to the center of the small circle. 

4 At the Point to copy to prompt, snap to the center of the arc at the upper left of the object. 

 
5 Pick to place the object, and press Enter. 

To make multiple copies: 

1 Select the small circle at the lower left of the object. 

2 From the Transform menu, click Copy. 

3 At the Point to copy from ( Vertical InPlace ) prompt, snap to the center of the small circle. 

 
Copy 
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4 At the Point to copy to prompt, begin picking points on the screen. 

Each time you pick, a circle will be copied to that location. 

 
5 Press Enter to end the command. 

Undo and Redo 
If you make a mistake or do not like the results of a command, use Undo. If you decide you want 
those undone results back after all, use Redo command. Redo restores the last thing undone. 

Rhino 
Button 

Mouse 
Button 

 
Command 

 
Description 

  

Left-click or 
Ctrl+Z 

Undo Cancels the effects of the last command. 

 

Right-click or 
Ctrl+Y 

Redo Restores the effects of undo.  

The number of undos kept in memory can be set in Rhino Options on the General page, 

If a command has an Undo option, type U to enter it. At the command prompt, type Undo. 

You cannot use the Undo command after you exit the modeling session or open a different model. 
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Rotate 
Use Rotate to move objects in a circular motion around a base point. For precise rotation, enter a 
number of degrees to rotate. Positive numbers rotate counterclockwise; negative numbers rotate 
clockwise. 

Option Description 
Copy Duplicates the object as it is rotated 

Exercise 33—Rotate  
1 Select the large slotted circle in the middle of the object. 

2 From the Transform menu, click Rotate. 

3 At the Center of rotation ( Copy=No ) prompt, snap to the center of the slotted circle. 

  
4 At the Angle or first reference point ( Copy=No ) prompt, type -28 and press Enter. 

 
Rotate 
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Group 
Grouping objects allows all members of the group to be selected as one. You can then apply 
commands to the entire group. 

Rhino 
Button 

Mouse 
Button 

 
Command 

 
Description 

  

Left-click or 
Ctrl+G 

Group Makes a group from selected objects. 

 

Left-click or 
Ctrl+Shift
+G 

Ungroup Removes grouping. 

 

Left-click AddToGroup To add objects to a group. 

 

Left-click RemoveFromGroup To remove objects from a group. 

 

Left-click SetGroupName To name groups 

Exercise 34—Grouping  

To group selected objects: 

1 Select the two circles that you placed. 

2 From the Edit menu, click Groups, then click Group. 

To add objects to a group: 

1 At the command prompt type AddT. 

 When the AddToGroup command completes, press Enter. 

2 At the Select objects prompt, select the polyline on the left, the original circle, and the slotted 
circle in the center. 

3 At the Select objects prompt, press Enter. 

4 At the Select group prompt, select one of the circles in the group. 

The objects are now part of the group. 
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To remove an object from a group: 

1 At the command prompt, type RemoveFr and press the Tab key, then press Enter. 

 When the RemoveFromGroup command completes, press Enter. 

2 At the Select objects to extract from group prompt, select the slotted circle. 

3 At the Select objects to extract from group prompt, press Enter. 

Mirror 
Mirror creates a copy of the objects flipped over a specified axis on the construction plane.  

Exercise 35—Mirror 
1 Select the group. 

2 From the Transform menu, click Mirror. 

3 At the Start of mirror plane ( Copy=Yes ) prompt, type 0,0 or snap to the end of the line at the 
lower right of the part. 

4 At the End of mirror plane ( Copy=Yes ) prompt, toggle Ortho on and pick directly above the 
previous point. 

  
5 Select the two groups. 

6 From the Edit menu, click Groups, then click Ungroup. 

 
Mirror 
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Join 
Join unites curves that meet at a common end, making a single curve. Join can unite curves that do 
not touch, if you select them after the command has started. As you select non-touching curves, a 
dialog box asks if you want to fill the gap. 

Exercise 36—Join 
1 Select the two polylines. 

2 From the Edit menu, click Join. 

 

Scale 
Scale changes the size of existing objects without changing their shape. This command scales three-
dimensional objects equally along all three axes. There are also 2-dimensional, one-dimensional, and 
non-uniform scale commands. 

Option Description 
Copy Preserves the object as it creates a new scaled one. 
Scale factor Inputs a value for scale factor. Less than one reduces the size, more than one increases the 

size. 

Exercise 37—Scale 
1 From the Edit menu, click Select, and then click Curves. 

2 From the Transform menu, click Scale, and then click Scale 2-D. 

3 At the Origin point ( Copy=No ) prompt, type 0,0 and press Enter. 

 
Join 
 

 
Scale2D 
Right-click for Scale2D 
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4 At the Scale factor or first reference point <1> ( Copy=No ) prompt, type .75 and press 
Enter. 

The whole part has been scaled to 75 percent of its original size. 

 

To scale using the reference point option: 

1 From the Edit menu, click Select, and then click Curves. 

2 From the Transform menu, click Scale, and then click Scale 2-D. 

3 At the Origin point ( Copy=No ) prompt, snap to the center of the slotted circle. 

4 At the Scale factor or first reference point <.75> ( Copy=No ) prompt, snap to the quadrant 
of the slotted circle. 

The radius of the slotted circle is the reference for the scale factor. 

  
5 At the Second reference point ( Copy=No ) prompt, type 1.375 and press Enter. 

The slotted circle now has a larger radius of 1.375. Everything else was scaled proportionally. 
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To make it solid: 

1 From the Edit menu, click Select, and then click Curves. 

2 From the Solid menu, click Extrude Planar Curves. 

3 At the Extrusion distance ( Direction Cap=Yes BothSides Tapered ) prompt, type 1 and press 
Enter. 

   

To scale in 3-D: 

1 From the Edit menu, click Select, and then click Polysurfaces. 

2 From the Transform menu, click Scale, and then click Scale. 

3 At the Origin point ( Copy=No ) prompt, type 0,0 and press Enter. 

4 At the Scale factor or first reference point <1> ( Copy=No ) prompt, type 1.5 and press 
Enter. 

 The solid is larger in every dimension. 

  

To scale in one dimension: 

1 From the Edit menu, click Select, and then click Polysurfaces. 

2 From the Transform menu, click Scale, and then click Scale 1-D. 

3 At the Origin point ( Copy=No ) prompt, type 0,0 and press Enter. 

4 At the Scale factor or first reference point <1.500> ( Copy=No ) prompt, type .5 and press 
Enter. 

 
Scale 
 

 
Scale1D 
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5 At the Scaling direction ( Copy=No ) prompt, move your cursor into the Front viewport, toggle 
Ortho on, and pick a point above the previous point. 

The object is half as thick. 

  

Array 
Use the Array commands to make multiple copies of selected objects. Array Rectangular makes rows 
and columns of objects. Array Polar copies objects in a circle around a center point 

Exercise 38—Array 

To create a rectangular array: 

1 Open the model T-Flange.3dm. 

2 Select the small cylinder (1) that is visible in the Top viewport. 

 
3 From the Transform menu, click Array, and then click Rectangular. 

4 At the Number in x direction <1> prompt, type 2 and press Enter. 

5 At the Number in y direction <1> prompt, type 2 and press Enter. 

6 At the Number in z direction <1> prompt, type 1 and press Enter. 

7 At the Unit cell or x distance prompt, type 4 and press Enter. 

 
Array Rectangular 
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8 At the Y distance or first reference point prompt, type 1.5 and press Enter. 

The cylinders are arrayed on the base of the flange. 

  

To create a 3-D array: 

1 Select the cylinder (1) that is visible in the Front viewport. 

 
2 From the Transform menu, click Array, and then click Rectangular. 

3 At the Number in x direction <2> prompt, type 2 and press Enter. 

4 At the Number in y direction <2> prompt, type 2 and press Enter. 

5 At the Number in z direction <1> prompt, type 2 and press Enter. 

6 At the Unit cell or x distance prompt, type 2 and press Enter. 

7 At the Y distance or first reference point prompt, type -2 and press Enter. 

8 At the Z distance or reference first point prompt, type -4.5 and press Enter. 

The cylinders are arrayed on both flanges. 

  

 
Array Rectangular 
 

The reason that negative 
numbers are used for the y and z 
spacing is because the hole is 
arrayed in the negative direction 
on those axes. 
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To make holes in the flange: 

1 Save your model. 

2 From the Solid menu, click Difference. 

3 At the Select first set of surfaces or polysurfaces. … prompt, pick the flange (1). 

4 At the Select first set of surfaces or polysurfaces. … prompt, press Enter. 

5 At the Select second set of surfaces or polysurfaces. Press Enter when done. 
( DeleteInput=Yes ) prompt, pick all of the cylinders (2) for the holes and press Enter. 

The cylinders are subtracted from the flange. 

  

To create a polar array: 

1 Open the model Wheel.3dm. 

2 Select the cylinder and the box in the Top viewport. 

 
3 From the Transform menu, click Array, and then click Polar. 

4 At the Center of polar array prompt, snap to the center of the wheel. 

5 At the Number of items <2> prompt, type 3 and press Enter. 

 
Boolean Difference 
 

 
Array Polar 
 

You must include the original and 
the copies as the number in the 
array. 
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6 At the Angle to fill <360> prompt, press Enter. 

The cylinders and ribs are arrayed in a circular pattern around the center of the wheel. 

 

To remove the holes from the wheel: 

1 Save your model. 

2 From the Solid menu, click Difference. 

3 At the Select first set surfaces or polysurfaces prompt, pick the wheel. 

4 At the Select first set of surfaces or polysurfaces. Press Enter for second set prompt, press 
Enter. 

5 At the Select second set of surfaces or polysurfaces. Press Enter when done. 
( DeleteInput=Yes ) prompt, pick all of the cylinders for the holes and press Enter. 

The cylinders are subtracted from the flange. 

  

To add the ribs to the wheel: 

1 From the Solid menu, click Union. 

2 At the Select surfaces or polysurfaces to union prompt, pick the wheel. 

 
Boolean Union 
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3 At the Select surfaces or polysurfaces to union. Press Enter when done prompt, pick each 
of the ribs and press Enter. 

 

Trim 
Trim cuts and deletes portions of an object to make it end precisely at its intersection with another 
object. 

Exercise 39—Trim 
1 Open the model Trim-Split.3dm. 

 
2 From the View menu, click Zoom, and then click Window. 

3 Make a window around the grid in the lower left corner of the Top viewport. 

 

 
Zoom Window 
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4 From the Edit menu, click Trim. 

5 At the Select cutting objects ( ExtendLines=Off UseApparentIntersections=Off ) prompt, select 
the two outside vertical lines in the grid. 

 
6 At the Select cutting objects ( ExtendLines=Off UseApparentIntersections=Off ) prompt, press 

Enter to go to the next stage of the command. 

7 At the Select object to trim. Press Enter to clear selection and start over ( ExtendLines=Off 
UseApparentIntersections=Off ) prompt, select each of the horizontal lines at their left and right 
ends. 

The lines are trimmed to the cutting edges. 

 
8 At the Select object to trim. Press Enter to clear selection and start over ( ExtendLines=Off 

UseApparentIntersections=Off ) prompt, press Enter. 

9 From the View menu, click Zoom, and then click Extents All. 

10 From the Edit menu, click Trim. 

11 At the Select cutting objects ( ExtendLines=Off UseApparentIntersections=Off ) prompt, select 
the surface that intersects the sphere in the Perspective viewport. 

 
Trim 
 

 
Zoom Extents All 
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12 At the Select cutting objects ( ExtendLines=Off UseApparentIntersections=Off ) prompt, press 
Enter. 

 
13 At the Select object to trim. … ( ExtendLines=Off UseApparentIntersections=Off ) prompt, 

select the right side of the sphere. 

The sphere is trimmed at the surface. 

 
14 At the Select object to trim. … ( ExtendLines=Off UseApparentIntersections=Off ) prompt, press 

Enter. 

Split 
Splits one object with another into two objects splits a curve at a point you specify. The Split 
command breaks the object where it intersects the cutting object but does not delete anything. 

Exercise 40—Split  
1 From the View menu, click Zoom, and then click Window. 

2 Make a window around the closed curve in the lower right corner of the Top viewport. 

3 From the Edit menu, click Split. 

4 At the Select objects to split prompt, select the closed curve. 

5 At the Select objects to split prompt, press Enter to go to the next stage of the command. 
 

Split 
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6 At the Select cutting objects ( Point ) prompt, select the lines and press Enter. 

 
7 At the Select cutting objects ( Point ) prompt, press Enter. 

The curve is separated into four curves precisely where the lines intersect it. 

 
8 From the View menu, click Zoom, and then click Extents All. 

9 From the Edit menu, click Split. 

10 At the Select objects to split prompt, select the sphere. 

11 At the Select cutting objects ( Isocurve ) prompt, select the surface that intersects the sphere 
and press Enter. 

The sphere is separated into two pieces precisely where the surface intersects it. 
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Extend 
Extend lengthens an object to make it end precisely at its intersection with another object or you can 
lengthen an object when there is no intersection. 

Exercise 41—Extend 
1 Open the model Extend.  

2 From the Curve menu, click Extend, and then click Extend Curve. 

3 At the Select boundary objects or enter extension length. Press Enter for dynamic extend 
prompt, select the line at the left. 

4 At the Select boundary objects or enter extension length. Press Enter for dynamic extend 
prompt, press Enter. 

5 At the Select curve to extend ( Type=Line ) prompt, select the left ends of the three curves. 

The line and curves extend to touch the boundary edge on the left. 

  
6 At the Select curve to extend ( Type=Line ) prompt, press Enter to end the command. 

To extend with some of the other options: 

1 From the Curve menu, click Extend, and then click Extend Curve. 

2 At the Select boundary objects or enter extension length. Press Enter for dynamic extend 
prompt, select the curve at the right. 

3 At the Select boundary objects or enter extension length. Press Enter for dynamic extend 
prompt, press Enter. 

4 At the Select curve to extend ( Type=Line ) prompt, select the right end of the line. 

The line is extended straight. 

5 At the Select curve to extend ( Type=Line ) prompt, type T and press Enter. 

6 At the Type <Line> ( Line Arc Smooth ) prompt, type A and press Enter. 

7 At the Select curve to extend ( Type=Arc ) prompt, select the right end of the curve. 

The curve continues with a tangent arc to the boundary edge. 
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8 At the Select curve to extend ( Type=Arc ) prompt, type S and press enter. 

9 At the Type <Arc> ( Line Arc Smooth ) prompt, type S and press Enter. 

10 At the Select curve to extend ( Type=Smooth ) prompt, select the right end of the arc. 

The arc continues with a tangent curve. 

 

To extend to a surface: 

1 From the Curve menu, click Extend, and then click Extend Curve. 

2 At the Select boundary objects or enter extension length. … prompt, select the cylinder on 
the left. 

3 At the Select boundary objects or enter extension length. … prompt, select the surface on 
the right. 

4 At the Select boundary objects or enter extension length. … prompt, press Enter. 

5 At the Select curve to extend ( Type=Smooth ) prompt, type T and press Enter. 

6 At the Type <Smooth> ( Line Arc Smooth ) prompt, type L and press Enter. 

7 At the Select curve to extend ( Type=Line ) prompt, select both ends of the line and the curve. 

The curves extend to the surface of the sphere and to the surface. 
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To extend a curve without boundary edges:  

1 From the Curve menu, click Extend, and then click By Line. 

2 At the Select curve to extend ( Type=Line ) prompt, select near the curve in the upper right 
side. 

3 At the End of extension prompt, pick a point. 

The curve is extended as a tangent line to the point you picked. 

  
4 From the Curve menu, click Extend, and then click By Arc. 

5 At the Select curve to extend ( Type=Arc ) prompt, select near the upper end of the line on the 
left. 

6 At the Center of arc extension prompt, type 1 and press Enter to set the radius. 

7 At the Center of arc extension prompt, pick a point to the left of the line. 

8 At the End of extension prompt, pick an end for the arc. 

  

 
Extend by Line 
 

 
Extend by Arc 
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Offset 
Offset creates an object parallel or concentric to another object. Use Offset to create specialized 
copies, such as parallel lines, concentric circles, and concentric arcs, through specified points or at 
pre-set distances. 

Exercise 42—Offset 
1 Open the model Offset.3dm. 

2 Maximize the Top viewport. 

3 From the Curve menu, click Offset. 

4 At the Select curve to offset ( Distance=1 Corner=Sharp ThroughPoint Tolerance ) prompt, 
select the line. 

5 At the Through point ( Distance=1 Corner=Sharp ThroughPoint Tolerance ) prompt, pick on the 
upper right side of the line. 

A parallel line is created. 

  

To offset with the through point option: 

1 From the Curve menu, click Offset. 

2 At the Select curve to offset ( Distance=1 Corner=Sharp ThroughPoint Tolerance ) prompt, 
select the circle.  

3 At the Through point ( Distance=1 Corner=Sharp ThroughPoint Tolerance ) prompt, type T and 
press Enter. 

 
Offset 
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4 At the Side to offset ( Corner=Sharp Tolerance ) prompt, snap to the end of the line you offset. 

A concentric circle is created that goes through the end point of the line. 

  

Offset Using Corner Options 

Sharp 

1 From the Curve menu, click Offset. 

2 At the Select curve to offset ( Distance=4.82974 Corner=Sharp ThroughPoint Tolerance ) 
prompt, select the polyline. 

3 At the Through point ( Distance=4.82974 Corner=Sharp ThroughPoint Tolerance ) prompt, type 
1 and press Enter. 

4 At the Through point ( Distance=1 Corner=Sharp ThroughPoint Tolerance ) prompt, pick inside 
the polyline. 

The polyline is offset with sharp corners. 

 

Round 

1 Press Enter to repeat the command. 

2 At the Select curve to offset ( Distance=1 Corner=Sharp ThroughPoint Tolerance ) prompt, 
select the polyline. 

3 At the Through point ( Distance=1 Corner=Sharp ThroughPoint Tolerance ) prompt, type C and 
press Enter. 

4 At the Corner <Sharp> ( Sharp Round Smooth Chamfer ) prompt, type R and press Enter. 
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5 At the Side to offset ( Distance=1 Corner=Round ThroughPoint Tolerance ) prompt, pick outside 
the polyline.  

The polyline is offset, but the corners are rounded with arcs. 

 

Smooth 

1 Press Enter to repeat the command. 

2 At the Select curve to offset ( Distance=1 Corner=Round ThroughPoint Tolerance ) prompt, 
select the polyline. 

3 At the Through point ( Distance=1 Corner=Round ThroughPoint Tolerance ) prompt, type 2 and 
press Enter. 

4 At the Through point ( Distance=2 Corner=Round ThroughPoint Tolerance ) prompt, type C and 
press Enter. 

5 At the Corner <Round> ( Sharp Round Smooth Chamfer ) prompt, choose the Smooth option, 
and press Enter. 

6 At the Through point ( Distance=2 Corner=Smooth ThroughPoint Tolerance ) prompt, pick the 
outside of the polyline.  

The polyline is offset, but the corners are rounded with curvature continuous blend curves. 

 

Distance 

1 At the Select curve to offset ( Distance=2 Corner=Smooth ThroughPoint Tolerance ) prompt, 
select the free-form curve.  

2 At the Through point ( Distance=2 Corner=Smooth ThroughPoint Tolerance ) prompt, type 1 and 
press Enter. 
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3 At the Through point ( Distance=1 Corner=Smooth ThroughPoint Tolerance ) prompt, pick on 
the one side of the curve.  

4 Press Enter to repeat the command. 

5 At the Through point ( Distance=1 Corner=Smooth ThroughPoint Tolerance ) prompt, pick on 
the other side of the curve. 

  
6 Select the arc.  

7 Press Enter to repeat the offset command. 

8 At the Through point ( Distance=1 Corner=Smooth ThroughPoint Tolerance ) prompt, pick on 
the left side of the arc. 

To offset a surface: 

1 From the Surface menu, click Offset. 

2 At the Select surface or polysurface to offset prompt, select one of the purple surfaces, and 
press Enter.  

3 At the Offset distance <1> ( Flip Solid Loose Tolerance ) prompt, place your cursor over the 
surface and click your left mouse button. 

Notice that the direction of the arrows changed. The normal direction of the surface was flipped by 
the mouse click. If you have a positive number for offset distance, the surface will be offset in the 
direction of the normal. If you have a negative number it will offset the opposite direction 

The normals should be pointed toward the concave side of the surface. 
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4 At the Offset distance <1> ( Flip Solid Loose Tolerance ) prompt, press Enter. 
The surface is offset in the direction of the normals. 

 

To offset a surface to a solid: 

1 Select the other purple surface. 

2 From the Surface menu, click Offset. 

3 At the Offset distance <1> ( Flip Solid Loose Tolerance ) prompt, click on the surface to change 
the normal direction if necessary. 

 
4 At the Offset distance <1> ( Flip Solid Loose Tolerance ) prompt, choose the Solid option and 

press Enter. 

5 At the Offset distance <1> ( Flip Loose Tolerance ) prompt, press Enter to create the offset 
surface and the surfaces needed to make the solid. 

 



 

Notes: 

Robert McNeel & Associates 130 

To offset a polysurface: 

1 Select the cylinder. 

2 From the Surface menu, click Offset. 

The normals on a closed polysurface will always point to the outside. 

 
3 At the Offset distance <1> ( Flip Solid Loose Tolerance ) prompt, press Enter. 

Each surface of the polysurface is offset as a separate piece. 
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Exercise 43—Practice 
1 Start a new model. Save as Gasket1 

2 Use Circle, Arc, Trim, Fillet, and Join to create the part shown. 

 

 

3 Use Extrude Planar Curve on the Solid menu to create the 3-D part. The extrusion thickness is 
.125. 
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Exercise 44—Practice 
1 Start a new model. Save as Cam. 

2 Use Circle, Arc, Line, Trim, Join, and Array to draw the part shown. 

 

 

3 Use Extrude Planar Curve on the Solid menu to create the 3-D part. The extrusion thickness 
is 0.5. 

Exercise 45—Practice 
1 Start a new model. Save as Link. 

2 Use Line, Arc, Trim, Offset, Join, Fillet and Circle to draw the part shown. 

 

 

3 Use Extrude to create the 3-D part. The extrusion thickness is .5. 
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Exercise 46—Practice 
1 Start a new model. Save as Building. 

2 Use Line, Arc, Trim, Offset, Curve, Fillet and Circle to draw the layout of the building shown. 
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6  

 

 

 
 
Point Editing  

 
You can display the control points or the edit points of an object so that you can adjust the shape of 
an object, rather than manipulating the whole object at once. That is called control point editing. 

You can use point editing on meshes, curves, and surfaces, but not on polysurfaces or solids. 

Rhino’s curves are represented internally with non-uniform rational B-splines ( NURBS ). Three things 
determine the shape of a NURBS curve: 

• A list of points called control points 

• Degree 

• A list of numbers called knots 

If you change any of these things, it changes the shape of the curve. 

A few facts about control points, edit points, and knots 
• Control points do not have to be on the curve.  

• Edit points are always on the curve. 

• Rhino lets you edit curves and surfaces by moving control points and edit points. 

• Knots are parameters (that is, numbers, not points). 

• Adding knots to a curve or surface lets you control the movement of the object during control-
point editing. 
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Exercise 47—Control point editing 
In this exercise we are going to experiment with moving control points. Understanding how curves and 
lines react when control points are moved is very important to understanding NURBS modeling. 

To edit control points: 

1 Open the model Control Point.3dm. 

There are pairs of curves with different degrees in the model. 

 
2 Turn Ortho and Snap on. 

3 From the Edit menu, click Select, and then click Curves. 

4 From the Edit menu, click Point Editing, and then click Control Points On. (Press F10.) 

 
5 In the Front viewport, select the middle row of points. 

6 Drag the points vertically, 5 units. 

 
7 In the Front viewport, select two rows of points on either side of the center. 

 
PointsOn 
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8 Drag the points vertically, 4 units. 

 
Notice that the degree 1 curves (polylines) come to a point at each control point and the control 
points are exactly on the curve. When a curve or polyline bends at a point like this it is called a 
kink. If you create a surface from a curve that has a kink, it will have a seam at the kink. 

The degree 3 and 5 curves are smooth. The degree 3 curves have more curvature that the 
degree 5 curves. Individual points have more influence on a small area of the curve with degree 3 
curves, while points have greater influence over a wider span of the curve with degree 5 curves.  

  
9 Press Esc twice to turn off the control points.  

 
10 Select the curves. 

11 From the Surface menu, click Loft. 
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12 In the Loft options dialog box, click OK. 

Because the degree 1 curves were included in the loft, a polysurface is created with a seam at 
each kink.  

 
13 Select the surface. 

14 Turn on the control points. 

The points do not turn on and the following message is displayed on the command line: 

Cannot turn on points for polysurfaces. 

15 Undo the loft. 

To change the polylines into curves without kinks: 

1 From the Curve menu, click Edit Tools, and then click Rebuild. 

2 At the Select curves to rebuild prompt, select both polylines. 

3 At the Select curves to rebuild prompt, press Enter. 

4 In the Rebuild Curve dialog box change the point count to 7 and the degree to 3, and click OK. 

A degree 3 curve cannot have kinks. The curve smoothes and changes shape. 

 

 

To loft a surface over the curves: 

1 Select all of the curves. 

2 From the Surface menu, click Loft. 

 
Rebuild 
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3 In the Loft Options dialog box, click OK. 

A single surface appears over the curves. The surface can be edited with control points. 

 

To rebuild a surface: 

1 Select the surface. 

2 From the Surface menu, click Edit Tools, then click Rebuild. 

3 In the Rebuild Surface dialog, change the point count to 8 in both the U and V direction. Change 
the degree to 3 for both U and V. 

The surface is smoother with fewer control points. 

 

 

Nudge Controls 
Another method to move control points and other geometry in a more subtle way is to use the Nudge 
keys. The nudge keys are the arrow keys on the keyboard activated with the Alt, Ctrl, and Shift keys. 

 
Rebuild Surface  
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To change the nudge settings: 

1 From the Tools menu, click Options. 

2 In the Options dialog box, on the Modeling Aids page, note the Nudge settings.  

Any of these values can be changed. 

 

To use Nudge commands to move control points: 

1 Select a control point in the Front viewport. 

2 Hold down the Alt key down and press an arrow key. 

Notice that it moves (nudges) the point a small amount. 

3 Hold the Alt and the Ctrl key down and press another arrow key. 

The movement is much smaller. 
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4 Hold the Alt and the Shift key down and press another arrow key. 

The movement is magnified. 

  
5 Hold the Alt and press the PageUp or PageDown key to nudge in the Z direction. 

To use set points to adjust points: 

1 Select all the points along the left edge of the surface. 

2 From the Transform menu, click Set Points. 

3 In the Set Points dialog box, check Set X, and uncheck Set Y and Set Z. 

 
4 In the Front viewport move the points and click. 

 The control points are aligned. 

  

 
Set Points  
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Exercise 48—Practice with curves and control point editing 
1 Start a new model. Save as Glass. 

 
2 Use the Curve command to create the half cross-section of the glass. 

To make it 3-D: 

1 From the Surface menu, click Revolve. 

2 At the Select curves to revolve prompt, select the curve you created, and press Enter. 

3 At the Start of revolve axis prompt, pick one end of the curve. 

4 At the End of revolve axis prompt, pick the other end of the curve. 

  
 

5 In the Revolve Options dialog box, check Deformable, then click OK. 

 
 

6 Save your model. 
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7 Experiment with adjusting the control points to see what happens. 

  
 

8 Incremental Save your model. 

9 Delete the surface. 

10 Change the original curve and make another revolved surface. 

  
11 Incremental Save your model. 

 

 

 





 

  

Part Three: 
3-D Modeling and Editing 
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7  

 

 

 
Creating Deformable 
Shapes 

 
When building models in Rhino, you should first determine which methods should be used for each 
part of the project. There are two basic ways to model in Rhino—free-form and accurate. Some 
models require more attention to exact dimensions because they might have to be manufactured or 
parts may have to fit together. Sometimes it is the shape of the object, not the accuracy that is 
important. These techniques can be merged together to create accurate, free-form shapes. This 
tutorial focuses only on the free-form, squishy aspect. The exact size and placement of the objects is 
not critical. The overall form is the main objective. 

This exercise shows: 

• Simple surface creation 

• Surface rebuilding 

• Control point editing 

• Curve creation ( drawing, projecting ) 

• Splitting surfaces with curves and surfaces 

• Blending between two surfaces 

• Lighting and rendering 

When you model the rubber ducky, you will use similar modeling techniques for the head and the 
body. You will create spheres that will be deformed to make the shapes.  

If you need to know more about control points and surfaces, search the Rhino Help index for “control 
points.” 
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Exercise 49—Creating a rubber duck 
1 Start a new model. Save as Duck. 

2 You can use layers to separate your parts, but for this model, it is not necessary. 

For more information about layers, look up “layer” the Rhino Help index. 

 

Create the body and head shapes 
The body and head of the ducky are created by modifying two spheres. The size and placement of the 
spheres does not need to be exact. 

To create the basic shapes: 

1 From the Solid menu, click Sphere, and then click Center, Radius. 

2 At the Center of sphere ( Diameter 3Point Tangent AroundCurve ) prompt, pick a point in the 
Front viewport. 

3 At the Radius <1> ( Diameter ) prompt, pick another point in the same viewport to create a 
sphere. 

4 Repeat this procedure for the second sphere. 

  

To make the spheres deformable:  

1 Select both spheres. 

2 From the Surface menu, click Edit Tools, then click Rebuild. 

 
Sphere 
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3 In the Rebuild Surface dialog box, change the Point Count to 8 for both U and V. 

Change the Degree to 3 for both U and V. 

Check Delete Input, clear Current Layer and ReTrim, and click OK. 

The spheres are now deformable. Having more control points allows more control over smaller 
parts of the surface. A degree-three surface will have a smoother shape when deformed. 

 

 

To modify the body shape: 

1 Select the large sphere. 

2 From the Edit menu, click Control Points, and then click Control Points On. 

3 In the Front viewport select the control points near the bottom of the sphere. 

To window select, drag a box left to right around the control points. 

  

 
Rebuild Surface  
 

 
Control Points On  
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4 From the Transform menu, click Set Points. 

5 Make the Set Points dialog box look like this, and click OK. 

 
6 Drag the selected control points up. 

This aligns all of the selected control points to the same world z-value (vertical in Front viewport), 
flattening the surface. 

  

To scale the sphere shape: 

1 Turn off control points and select the body shape. 

2 From the Transform menu, click Scale, then click Scale1D. 

3 At the Origin point ( Copy=No ) prompt, type 0 and press Enter. 

4 At the Scale factor or first reference point <1> ( Copy=No ) prompt, with Ortho on, pick a 
point to the right in the Front viewport. 

 
Set Points  
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5 At the Second reference point ( Copy=No ) prompt, pick a point further to the right in the 
Front viewport. 

The body will be shaped more like an ellipsoid. 

  

To reshape the chest and tail 

1 Window select the control points at the top right of the body, and drag them to the right to bulge 
out the chest. 

   

2 Window select the control points at the upper left edge of the body, and drag them up to form the 
tail. 

Notice in the Top viewport that two control points are selected, though in the Front viewport, it 
looks like only one is selected. This is because the second control point is directly behind the one 
you can see in the Front viewport. 
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To add control for further shaping the tail: 

Before we start to edit the tail further, we will add an additional set of points to the tail portion of 
the body. 

1 From the Edit menu, click Control Points, and then click Insert Knot. 

2 At the Select curve or surface for knot insertion prompt, pick the body surface. 

A surface isocurve will be displayed. It will either be in the U or the V direction.  

3 At the Point on surface to add knot ( Automatic Symmetrical=No Direction=U ) prompt, type V 
and press Enter to change the direction if necessary. 

4 At the Point on surface to add knot ( Automatic Symmetrical=No Direction=V ) prompt, pick a 
point midway between the tail and the center of the body. 

5 At the Point on surface to add knot ( Automatic Symmetrical=No Direction=V ) prompt, press 
Enter. 

A new set of points in the V direction have been added to the body. 

 
6 Window select the control points at the upper part of the new isocurve, and drag them down to 

further form the tail and the body. 

  
7 You can adjust the control points further until you get the shape you want. 

8 Save your model. 
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To create the head: 

1 In the Front viewport, select the small sphere. 

2 From the Edit menu, click Control Points, and then click Control Points On. 

3 Select the control points on the right side and drag them to begin forming the bill. 

  
4 Window select the control points further back on the same isocurve and drag them forward to 

widen the bill. 

   
5 Window select control points at the top of the bill and drag them down as shown below. 

   
6 Press Esc to turn control points off. 

Remember to use a window to 
select the control points. There 
may be multiple control points in 
the same location in this view. 
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Separate the bill from the head 
For the final rendering, the bill must be a different color from the body. To do this, they must be 
separate surfaces. You can split a single surface into multiple surfaces many ways. The following 
technique is just one. 

To split a surface with a curve: 

1 In the Front viewport create a curve that looks like the illustration below. 

 
2 Select the head. 

3 From the Edit menu, click Split. 

4 At the Select cutting objects. Press Enter to clear selection and start over ( Isocurve ) 
prompt, select the curve you just created. 

5 At the Select cutting objects. Press Enter when done ( Isocurve ) prompt, press Enter. 

The bill and head are now separate surfaces so they can be rendered with different colors. 
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Create the duck’s neck 
The ducky needs a neck. You will first make an edge on the surface of the head and a corresponding 
edge on the surface of the body so you can create a blended surface between the two edges. 

To trim the head: 

1 Draw a Line across the bottom of the head. 

 
2 Select the line you just created. 

3 From the Edit menu, click Trim. 

4 At the Select object to trim. Press Enter to clear selection and start over ( ExtendLines=No 
UseApparentIntersections=No ) prompt, select the bottom edge of the head. 

The bottom of the head is trimmed. 
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To cut a hole in the body that matches the opening in the bottom of the head: 

1 From the Surface menu, click Extrude, and then click Straight. 

2 At the Select curves or surfaces to extrude prompt, select the edge curve at the bottom of the 
head. 

3 At the Select curves or surfaces to extrude prompt, press Enter. 

4 At the Extrusion distance ( Direction BothSides=No Cap=No Mode=Straight ) prompt, drag the 
extruded surface until it intersects the top of the duck body and click. 

  
5 Select the cylindrical surface you extruded. 

6 From the Edit menu, click Trim. 

7 At the Select object to trim. … ( ExtendLines=No UseApparentIntersections=No ) prompt, select 
the part of the body on the inside of the extruded surface. 

8 At the Select object to trim. … prompt, press Enter. 

A hole will be created in the body. 

  
9 Delete the extruded surface. 

10 Save your model. 

 
Extrude  
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To create the blend surface between the head and body: 

1 From the Surface menu, click Blend Surface. 

2 At the Select segment for first edge ( PlanarSections Continuity=Curvature ) prompt, select the 
edge curve at the bottom of the head. 

3 At the Select segment for second edge … prompt, press select the edge of the hole in the 
body.  

 
4 At the Adjust curve seams … prompt, press Enter. 

5 In the Blend Bulge dialog box, click OK. 

A surface is blended between the body and the head. 

 

 
6 Save your model. 

 
Blend Surface  
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To join the parts: 

1 Select the body the blend surface and the back of the head. 

2 From the Edit menu, click Join. 

The three surfaces are joined into one. The bill is left separate for rendering purposes. 

  

To make an eye: 

1 From the Solid menu, click Ellipsoid. 

2 Toggle Ortho and Snap on to help. 

3 At the Ellipsoid center … prompt, pick a point in the Front viewport. 

4 At the End of first axis … prompt, pick a point in the vertical direction. 

5 At the End of second axis prompt, pick a point that creates an elliptical shape. 

The order of the first two points is important to correctly orient the isocurves on the surface. 

  

 
Join  
 

 
Ellipsoid  
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6 At the End of third axis prompt, pick a point in the Top viewport that creates a round, flat 
ellipsoid. 

  

To make the pupil for the eye: 

To be able to assign a different color for the pupil of the eye, the ellipsoid surface has to be split 
into two parts. In this example we will use an isocurve to split the ellipsoid into two parts. 

1 Select the ellipsoid. 

2 From the Edit menu, click Split. 

3 At the Select cutting objects. … ( Isocurve ) prompt, click Isocurve. 

 
4 At the Split point ( Direction=U ) prompt, pick on the top part of the surface to define an 

isocurve for the split. 

5 At the Split point ( Direction=U ) prompt, press Enter. 

The surface is split at the isocurve. 

  
6 Select the surface at the top of the ellipsoid. 
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7 From the Edit menu, click Object Properties. 

8 In the Properties window, on the Material page, click Basic, click on the Color button, and 
select a color for the pupil of the eye, like black. 

 

 

9 From the Render menu, click Render Preview. 

To group the parts of the eye: 

1 Select the both eye surfaces. 

2 From the Edit menu, click Groups and then click Group. 

 The eye parts are grouped as one object. 

To move the eyes to the surface of the head: 

1 Select the eye group. 

2 From the Transform menu, click Orient, and then click On Surface. 

 
Properties 
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3 At the Point to orient from ( OnSurface ) prompt, snap to the center of the eye in the Top 
viewport. 

  
4 At the Surface to orient on prompt, click on the head. 

5 At the Point on surface to orient to ( Align=U Copy=Yes FlipNormal=No Mirror=None 
SwapUV=No ) prompt, change the Copy option to No. 

6 At the Point on surface to orient to … prompt, click the location for the eye. 

  
7 Mirror the eye to the other side of the head. 
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Render a picture of the ducky 
Rendering creates a “realistic” picture of your model with colors you assign. These render colors are 
different from the layer colors you might be using, which control the display in wireframe and shaded 
mode. 

To render the ducky: 

1 Select the beak.  

2 From the Edit menu, click Object Properties. 

3 In the Properties window, on the Material page, click Basic and click the color swatch. 

4 In the Select Color dialog box, select a color for the beak, like orange. 

5 Select the body. 

6 From the Edit menu, click Object Properties. 

7 In the Properties window, on the Material page, check Basic and select a color for the body, 
like yellow. 

8 From the Render menu, click Render. 

 

 
Render 
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To place lights: 

1 From the Render menu, click Create Spotlight. 

2 At the Base of cone ( Vertical Diameter 3Point Tangent AroundCurve ) prompt, select a point in 
the middle of the model. 

3 At the Radius <1.000> ( Diameter ) prompt, drag the radius until it is approximately three 
times as large as the model. 

4 At the End of cone prompt, pick a point in the Top viewport while holding the Ctrl key down to 
activate elevator mode.  

In the Front viewport pick a point slightly above the object. 

5 From the Render menu, click Render. 

   
 

 

 
Spotlight 
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8  

 

 

 
 
Modeling with Solids 

 
Modeling solids in Rhino is easy. There are several commands that enable you create and edit solid 
objects.  

Solids in Rhino are closed surfaces or polysurfaces that enclose a volume. Some of the solid primitives 
are closed single-surfaces carefully edge-matched, others are polysurfaces. 

Rhino’s polysurface objects are not deformable. You cannot turn control points on and use them to 
deform the polysurface.  

Button Command Description 

 

Box Draw a rectangular box from two diagonal corners and a height. 
 

 

Box 3Point Draw a box from two adjacent corners, a point on the edge across from them, 
and a height. 

  

Sphere Draw a sphere from a center point and a radius. 

  

Sphere Diameter Draw a sphere from the two ends of a diameter. 

  

Sphere 3Point Draw a sphere from three points on its surface. 

  

Cylinder  
 

Draw a solid cylinder from a center point, a radius, and a height. 

  

Tube Draw a solid tube from a center point, two radii, and a height. 
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Button Command Description 

 

Cone  Draw a solid cone from a base point, a base radius, and a height. 

 

TCone  Draw a truncated cone that ends in a circular plane from a base point, two radii, 
and a height. 

  

Ellipsoid  
 

Draw an ellipsoid from a center point, and three axis endpoints. 

  

Torus  Draw a solid Torus from a center point, a radius for the center of the tube, and a 
tube radius.  

 

Pipe  
 

Draw a pipe around an existing curve. The pipe has a circular cross-section and 
optional caps at the ends.  
The Thick option lets you specify two radii at each end of the curve to create 
pipes with holes bored through the middle like tubing. 

 

TextObject Draw text as outline curves, surfaces, or solids. 

 

Extrude Draw a solid by extruding a closed planar curve vertically.  

 

Extrude  Creates a solid by extruding a surface vertically. 
 

 

Cap Creates planar surfaces to close planar holes in a surface or partial solid. 

 

BooleanUnion Boolean operation in Rhino to combine solids. 

 

BooleanDifference Boolean operation in Rhino to subtract surfaces and solids from one another. 

 

BooleanIntersection Boolean operation in Rhino to create the intersection of two surfaces or solids. 
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Exercise 50— Model a bar with text 
In the following exercise we will make a solid primitive, extract some surfaces, rebuild a surface and 
deform it, join the new surfaces into a solid, fillet the edges, add text to a surface, and do a Boolean 
operation on the solid. 

1 Start a new model using the Millimeters template. Save as Bar. 

2 From the Solid menu, click Box. 

3 At the First corner of base ( 3Point Vertical Center ) prompt, type 0,0 and press Enter. 

4 At the Other corner of base or length prompt, type 15 and press Enter. 

5 At the Width. Press Enter to use length prompt, type 6 and press Enter. 

6 At the Height. Press Enter to use length prompt, type 1 and press Enter. 

 

To edit the box: 

1 From the Solid menu, click Extract Surface. 

2 At the Select surfaces to extract ( Copy ) prompt, select the top and both ends.  

3 At the Select surfaces to extract. Press Enter when done ( Copy ) prompt, press Enter.  

 

 
Box 
 

 
Extract Surface 
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4 Select the two ends and delete them. 

 
5 Select the top extracted surface. 

6 From the Surface menu, click Edit Tools, then click Rebuild. 

7 In the Rebuild Surface dialog box, set the Point count to 4 and the Degree to 3 for both U 
and V.  

 

 

8 From the Edit menu, click Point Editing, then click Control Points On. 

9 In the Right viewport, window select the middle points and drag them up approximately one unit. 

  
10 Turn off control points. 

11 Select all of the surfaces. 

 
Rebuild Surface 
 

 
Control Points On 
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12 From the Edit menu, click Join. 

The surfaces are joined making an open polysurface. 

 
13 Select the polysurface. 

14 From the Solid menu, click Cap Planar Holes. 

Two end caps are created. 

 

To fillet the edges: 

1 From the Solid menu, click Fillet Edge. 

2 At the Select edges to fillet ( Radius=1 ) prompt, select the vertical edges. 

3 At the Select edges to fillet. Press Enter when done ( Radius=1 ) prompt, press Enter. 

  
4 From the Solid menu, click Fillet Edge. 

5 At the Select edges to fillet ( Radius=1 ) prompt, type .2 and press Enter. 

6 At the Select edges to fillet ( Radius=0.2 ) prompt, window select the entire bar to get the 
horizontal edges. 

 
Cap Planar Holes 
 

 
Fillet Edge  
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7 At the Select edges to fillet. … ( Radius=0.2 ) prompt, press Enter. 

  
8 Make a copy of the bar and lock it. 

We will use the second bar for another technique later in the exercise. 

To make solid text: 

1 From the Solid menu, click Text. 

2 In the Text Object dialog box, select a Font. 

Under Create click Solids. 

Under Text size, set the Height to 3.00 and the Solid thickness to 1.00. 

Place the text in the Top viewport. 

 

  

3 Drag the text to the middle of the bar and click. 

4 In the Front or Right viewport, drag the text until it protrudes through the top surface. 

 
TextObject 
Look for this button 
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To engrave the text in the bar: 

1 Select the bar. 

2 From the Solid menu, click Difference. 

3 At the Select second set of surfaces or polysurfaces ( DeleteInput=Yes ) prompt, window 
select all of the text.  

4 At the Select second set of surfaces or polysurfaces. Press Enter when done 
( DeleteInput=Yes ) prompt, press Enter. 

The text is embossed into the bar.  
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To make a label: 

1 Hide the finished bar and Unlock the copy of the bar. 

2 From the Solid menu, click Extract Surface. 

3 At the Select surfaces to extract ( Copy ) prompt, select the top surface.  

4 At the Select surfaces to extract ( Copy ) prompt, press Enter.  

 
5 Select the lower part of the bar and lock it. 

6 Make the Top viewport active. 

7 From the Solid menu, click Text. 

8 In the Text Object dialog box, under Create, click Curves, and click OK. 

 

 

9 Place the text in the Top viewport. 

10 Drag the text to the middle of the bar and click. 
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To project the text curves through the bar: 

1 Select the text (curves). 

2 From the Curve menu, click Curve From Objects, and then click Project. 

3 At the Select surfaces or polysurfaces to project onto prompt, select the top surface in the 
Top viewport. 

The Project command projects objects perpendicular to the construction plane. 

 
4 Delete the original text curves. 

5 Select the top surface. 

6 From the Edit menu, click Split. 

7 At the Select cutting objects. … prompt, window select the text curves, and press Enter. 

The curves have split the surface. Each part of the text is a separate surface. 

 
8 From the Edit menu, click Select, then click Curves.  

This will select the curves you used to split the surface. 

9 From the Edit menu, click Visibility, then click Hide to hide the curves. 

To change the render color of the text: 

1 Select the text surfaces. 

2 From the Edit menu, click Object Properties. 

 
Project 
Look for this button 
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3 In the Properties window, on the Material page, click Basic and select a color for the text, 
like red. 

 
4 Right click on the Perspective viewport title. 

5 From the menu, click Rendered Display. 

The letters render in a different color. 
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To emboss the text in the bar: 

1 Click in the Top viewport. 

2 From the Edit menu, click Select, then click Previous Selection. 

This selects the text surfaces again. 

3 From the Solid menu, click Extrude Solid, then click Straight. 

4 At the Extrusion distance ( Direction BothSides=No Cap=Yes Mode=Straight ) prompt, type .2 
and press Enter. 

The surfaces are extruded perpendicular to the active construction plane. 

 
Notice that the top of the text follows the curvature of the original surface. 

 
 

 
Extrude Surface 
Look for this button 
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9  

 

 

 
 
Creating Surfaces 

 
A Rhino surface is similar to a piece of stretchy fabric. It can take on many different shapes.  

Surfaces are bounded by curves called edges. To visualize the surface shape Rhino displays a grid of 
isoparametric curves (isocurves) on the surface. 

Surfaces have an area, their shape can be changed by moving control points, and they can be 
meshed. 

Button Command Description 

 

SrfPt Creates a surface by picking three or four points in space for corners. 

 

EdgeSrf Creates a surface by selecting two, three, or four existing curves whose ends 
meet exactly. 

 

PlanarSrf Creates a surface from planar curves that enclose an area. 

 

Patch Creates a surface that approximates a set of curves and/or point objects. 

 

Revolve Revolves a curve around an axis to create a surface. 

 

Loft Creates a surface from shape curves; the normal, loose, and tight options make 
a surface with no creases as it passes over the shape curves.  
The StraightSections option creates a surface with creases at each shape curve 
and straight sections between the shapes curves. 

 

Sweep1 Creates a surface from shape curves that follow along a rail curve that defines 
one edge of the surface. 
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Button Command Description 

 

Sweep2 Creates a surface from shape curves that follow along two rail curves that define 
two edges of the surface. 

 

FilletSrf Creates a fillet or round between two surfaces. 

 

BlendSrf Makes a smooth surface between two existing surfaces 

 

RailRevolve Revolves a shape curve holding one end along a rail curve. This command is 
very useful for putting a smooth end cap on an irregularly shaped surface. 

 

Extrude Extrudes a curve perpendicular to the construction plane with option to taper the 
surface with a draft angle.  

 

Extrude AlongCurve Extrudes a curve following along a second curve. 

 

Extrude ToPoint Extrudes a curve to a point. 

 

Plane Creates a rectangular planar surface parallel to the construction plane from two 
diagonal points. 
 

 

Plane 3Point Creates a rectangular planar surface from 3 points. 

 

Plane Vertical Creates a rectangular planar surface from 3 points that is vertical to the 
construction plane. 
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Exercise 51—Basic techniques for making surfaces 
1 Start a new model. Save as Surfaces. 

In this exercise, you will model some simple surfaces. 

2 Turn on Snap and Planar. 

3 From the Surface menu, click Plane, then click Corner to Corner. 

4 In the Top viewport, at the First corner of plane ( 3Point Vertical Center Deformable ) prompt, 
pick a point. 

5 At the Other corner or length prompt, pick another point to make a rectangular plane. 

 

To create a vertical plane: 

1 From the Surface menu, click Plane, and then click Vertical. 

2 At the Start of edge … prompt, snap to the End point at the right side of the surface. 

3 At the End of edge prompt, snap to the other End point at the right side of the surface. 

4 At the Height. Press Enter to use width prompt, drag your cursor up and pick. 

 

 
Plane 
Look for this button 

 
Plane Vertical 
Look for this button 
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To create a plane from 3 points: 

1 From the Surface menu, click Plane, and then click 3 Points. 

2 At the Start of edge … prompt, snap to the endpoint at the left of the first surface. 

3 At the End of edge prompt, snap to the other endpoint at the left side of the first surface. 

4 At the Width. Press Enter to use length prompt, pick a point in the Front viewport that is 
angled to the left and the same height as the vertical surface. 

  

To create a plane from corner points: 

1 From the Surface menu, click Corner Points. 

2 At the First corner of surface prompt, snap to an endpoint at the edge of the first surface (1). 

3 At the Second corner of surface prompt, snap to the endpoint at the edge of the first 
surface (2). 

4 At the Third corner of surface prompt, snap to an endpoint at the edge of the third surface (3). 

5 At the Fourth corner of surface prompt, snap to the other endpoint at the edge of the third 
surface (4). 

A surface will be created with corners at the points you selected. 

  

 
Plane 3 Points 
Look for this button 

 
Surface from 3 or 4 Corner Points 
Look for this button 
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To create a plane from edge curves: 

1 Draw a curve in the Top viewport that starts and ends at the top of the two vertical surfaces as 
shown below.  

 Planar mode keeps this curve on the same plane as the surface corners. 

  
2 From the Surface menu, click Edge Curves. 

3 At the Select 2, 3, or 4 curves prompt, select the three surface edges and the curve you 
created. 

A surface is created. 

  

 
Surface from Edge Curves 
Look for this button 
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To create a surface from planar curves: 

1 From the Surface menu, click Planar Curves. 

2 At the Select planar curves to build surface prompt, select the top edge of a surface you just 
created. 

3 At the Select planar curves to build surface. … prompt, select the other three edges and press 
Enter. 

A surface is created. 

   

 
Surface from Planar Curves 
Look for this button 
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Exercise 52—Extruding surfaces 
In this exercise, you will be creating a cordless phone using extrusions. To aid in organizing the 
model, surface and curve layers have been created. Make sure you change layers as you are making 
the extrusions.  

 
1 Open the model Extrude.3dm. 

2 Select the curve (1) as shown below. 

3 From the Surface menu, click Extrude, and then click Straight. 

4 At the Extrusion distance ( Direction BothSides=No Cap=No Mode=Straight ) prompt, type -3.5 
and press Enter. 

If the object being extruded is a planar curve, the curve is extruded perpendicular to the plane of 
the curve. 

  
5 Press Esc to unselect the curve. 

6 Change to the Bottom Surface layer. 

7 Repeat this process for the other curve (2). 

  

 
Extrude 
Look for this button 

If you do not get the answer you 
expected, undo and try picking 
near the other end of the path 
curve. 
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To extrude a curve along another curve: 

1 Change to the Top Surface layer. 

2 Select the curve on the left (3). 

3 From the Surface menu, click Extrude, and then click Along Curve. 

4 At the Select path curve ( Cap=No Mode=AlongCurve ) prompt, select the path curve (4) near 
its right end. 

The curve is extruded along the path of the secondary curve. 

  
5 Change to the Bottom Surface layer. 

6 Repeat this process for the other curve (5). 

  

To extrude a curve with a taper ( draft angle ): 

1 Change to the Top Surface layer. 

2 Select the curve on the right (1). 

3 From the Surface menu, click Extrude, and then click Tapered. 

4 At the Extrusion distance ( Direction DraftAngle=0 Cap=No Corners=Sharp Mode=Tapered ) 
prompt, click DraftAngle. 

5 At the Draft angle <0> prompt, type 3 and press Enter. 

 
Extrude Along Curve 
Look for this button 
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6 At the Extrusion distance ( Direction DraftAngle=3 Cap=No Corners=Sharp Mode=Tapered ) 
prompt, type .375 and press Enter. 

The curve is extruded with a three-degree draft angle in the positive direction on the y-axis. 

  
7 Change to the Bottom Surface layer. 

8 Select the same curve. 

9 From the Surface menu, click Extrude, and then click Tapered. 

10 At the Extrusion distance ( Direction DraftAngle=3 Cap=No Corners=Sharp Mode=Tapered ) 
prompt, type -1.375 and press Enter. 

The curve is extruded with a three-degree draft angle in the negative direction from the previous 
extrusion. 
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To create a surface from a planar curves: 

1 Change to the Top Surface layer. 

2 From the Surface menu, click Planar Curves. 

3 At the Select planar curves to build surface prompt, select the edge curves that bound the 
openings of the tapered extrusion at the top. 

4 At the Select planar curves to build surface. … prompt, press Enter. 

A surface is created at the end. 

  
5 Change to the Bottom Surface layer. 

6 Repeat this process for the other end. 

  
7 Select all of the top surfaces. 

8 From the Edit menu, click Join. 

4 surfaces or polysurfaces joined into 1. 

9 Repeat this for the bottom surfaces. 

 
Surface from Planar Curves 
Look for this button 
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To create an extruded surface on both sides of a curve: 

1 Turn on the Extrude Straight-bothsides layer. 

2 Select the freeform curve as shown. 

 
3 From the Surface menu, click Extrude, and then click Straight. 

4 At the Extrusion distance ( Direction BothSides=No Cap=No Mode=Straight ) prompt, click 
Bothsides. 

5 At the Extrusion distance ( Direction BothSides=Yes Cap=No Mode=Straight ) prompt, in the 
Front view drag so that it extends past the object and pick.  

The curve is extruded symmetrically from the curve.  

  

To split the surface: 

1 Select the extruded surface. 

2 From the Edit menu, click Split. 

3 At the Select cutting objects. Press Enter to clear selection and start over ( Isocurve ) 
prompt, click Isocurve. 

4 At the Split point ( Direction=U ) prompt, click Direction to change the direction of the isocurve 
if necessary. 

5 At the Split point ( Direction=V ) prompt, snap to the intersection where all three surfaces touch 
in the Top viewport. 
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6 At the Split point ( Direction=V ) prompt, press Enter. 

  
7 Select the left part of the split surface. 

8 From the Edit menu, click Layers, then click Change Object Layer. 

9 Make the Top Surface layer current and turn off the Bottom Surface layer. 

 

To join the surfaces using Boolean difference: 

Next you will use a Boolean operation to join and trim the surface and the polysurface. Before you 
start, you should analyze the surface to see which direction the surface normals are pointing and 
adjust them if necessary. As a general rule, if the normals are pointing toward each other the 
Boolean operations will work as expected. 

1 Select the surface. 

2 From the Analyze menu, click Direction. 

3 At the Press Enter when done ( UReverse VReverse SwapUV Flip ) prompt, click to change the 
direction or press Enter when it is pointing the direction as illustrated below. 

  
4 Repeat this process for the polysurface. 
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5 Select the polysurface. 

6 From the Solid menu, click Difference. 

7 At the Select second set of surfaces or polysurfaces ( DeleteInput=No ) prompt, click 
DeleteInput. 

8 At the Select second set of surfaces or polysurfaces. Press Enter when done 
( DeleteInput=Yes ) prompt, pick the surface and then press Enter. 

The surfaces are trimmed and joined. 

 
9 Repeat this process for the bottom surfaces. 

   
10 Use the FilletEdge command (Solid > Fillet Edge) with a radius of .2 to round the edges. 
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To create an extruded surface from a curve to a point: 

1 Turn on the Extrude to a point layer. 

2 Select the U-shaped curve. 

3 From the Surface menu, click Extrude, and then click To Point. 

4 At the Point to extrude to ( Mode=ToPoint ) prompt, select the point object near the top 
surface. 

The curve is extruded to the point. 

   
5 Use the BooleanDifference command (Solid menu: Difference) to remove the surface from the 

top of the phone. 

 
6 Repeat these steps for the bottom part of the phone. 

   
7 Save your model as Phone. 

 
Extrude To Point 
Look for this button 
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To create the buttons: 

1 Turn on the Curves for Buttons layer. 

2 In the Front view, window select the first column of buttons. 

Three curves are selected. 

. 

3 From the Solid menu, click Extrude Solid, then click Straight. 

4 At Extrusion distance ( Direction BothSides=No Cap=Yes Mode=Straight ) prompt, type -.2 and 
press Enter. 

5 Repeat these steps for the other columns of buttons. 

  
6 Use the FilletEdge command (Solid > Fillet Edge) with a radius of .05 to round the edges. 

The button edges are rounded. 

 
7 Save your model. 
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Exercise 53—Lofted surfaces 

 
1 Open the model Loft.3dm. 

2 Window select all of the curves. 

3 From the Surface menu, click Loft. 

A surface is fitted over the curves. 

 

 

4 In the Loft Options dialog box, switch Style to Straight sections, then click Preview. 

A surface is fitted through the curves, but the sections are straight between the curves. 

 

 

 
Loft 
Look for this button 
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5 In the Loft Options dialog box, switch Style to Loose, then click Preview. 

A surface is created that uses the same control points as the curves. The surface follows the 
curves more loosely. 

Use this option when you want the surface to conform to the control points of the input curve. 

 

 

6 In the Loft Options dialog box, switch Style to Normal, then click OK. 

7 Mirror the surface to create the other half and Join the two halves. 

 
To make a seat: 

1 Turn the Hull Curves layer off and turn the Seat Curves, and Seat layers on. 

2 Make the Seat Curves layer current. 

3 In the Front view, select the rounded rectangles. 
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4 From the Curve menu, click Curve From Objects, and then click Project. 

5 At the Select surfaces or polysurfaces to project onto prompt, select the hull. 

The curves will be projected to both sides of the hull surface. 

  
6 Select the curves on the surface. 

7 From the Surface menu, click Loft. 

8 At the Adjust curve seams ( Flip Automatic Natural ) prompt, press Enter. 

A surface is fitted over the curves that fits exactly with the shape of the hull. 

   

To create section curves from the surfaces: 

1 Select the hull. 

2 Change to the Section layer. 

3 From the Curve menu, click Curve From Objects, and then click Section. 

4 At the Start of section prompt, in the Top viewport, pick a point to the left at the center of the 
hull. 
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5 At the End of section prompt, with Ortho on, drag a line to the right and pick. 

A curve is generated on the surface. Repeat this at various locations. 

   

To create contour curves across the hull surfaces: 

1 Select the hull. 

2 Change to the Contour layer. 

3 From the Curve menu, click Curve From Objects, and then click Contour. 

4 At the Contour plane base point ( Range ) prompt, snap to the left end of the canoe. 

5 At the Direction perpendicular to contour planes prompt snap to the right end of the canoe. 

6 At the Distance between contours <1> prompt, press Enter. 

A curve is generated every foot along the hull. 
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To create an edge curve from the surfaces: 

1 Change to the Top Rail layer. 

2 From the Curve menu, click From Objects, and then click Duplicate Edge. 

3 At the Select edges to duplicate prompt, pick the top edge of the hull. 

4 At the Select edges to duplicate. Press Enter when done prompt, pick the other top edge and 
press Enter. 

A curve is generated at the edge of the surface. 

 
5 Turn off the Hull layer. 

You have a wireframe of curves that duplicate the hull surface. 
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Exercise 54—Revolved surfaces 
1 Open the model Revolve.3dm. 

2 Select the free-form curve 

3 From the Surface menu, click Revolve. 

4 At the Start of revolve axis prompt, select one end of the curve. 

5 At the End of revolve axis prompt, select the other end of the curve. 

  
6 In the Revolve Options dialog box, click OK. 

A surface is revolved around the axis line. 

 
 

 
Revolve 
Look for this button 
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Exercise 55—Using a rail revolve 
Rail Revolve lets you revolve around an axis and along a path curve. 

To create a rail revolve: 

1 Open the model Rail Revolve.3dm. 

2 Select the conic shaped curve. 

3 From the Surface menu, click Rail Revolve. 

4 At the Select rail curve ( ScaleHeight=No ) prompt, select the path curve. 

  
5 At the Start of RailRevolve axis prompt, select one end of the axis line. 

6 At the End of RailRevolve axis prompt, select the other end of the axis line. 

A surface is revolved around the axis that follows along the curve at the end of the object. 

   
 7 Turn the Bowl layer on and other layers off. 

8 Use Rail Revolve to make a bowl. 

  

 
Rail Revolve 
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Exercise 56—Using 1-rail sweeps to create surfaces 
1 Open the model 1 Rail Sweep.3dm. 

2 Select the three curves on the left. 

 
3 From the Surface menu, click Sweep 1 Rail. 

4 At the Adjust curve seams ( Flip Automatic Natural ) prompt, press Enter. 

 
5 In the Sweep 1 Rail Options dialog box, click OK. 

The two cross section shapes are blended along the rail curve to form the surface. 

 

 

To create a 1-rail sweep to a point: 

1 From the Surface menu, click Sweep 1 Rail. 

2 At the Select rail curve prompt, select the free-form curve on the right. 

3 At the Select cross section curves ( Point ) prompt, select the circle. 

 
Sweep along 1 Rail 
Look for this button 
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4 At the Select cross section curves ( Point ) prompt, click Point. 

5 At the Pick end point prompt, select the other end of the free-form curve. 

  
6 In the Sweep 1 Rail Options dialog box, then click OK. 

The cross-section will sweep to a point to form the surface. 
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Exercise 57—Using 2-rail sweeps to create surfaces 
 Open the model 2 Rail Sweep.3dm. 

 

To create the base part: 

1 Change to the Base Surface layer. 

2 From the Surface menu, click Sweep 2 Rails. 

3 At the Select rail curves prompt, select the two profile curves. 

 
4 At the Select cross section curves ( Point ) prompt, select the cross-section curves. 

5 At the Select cross section curves ( Point ) prompt, press Enter. 

6 At the Adjust curve seams ( Flip Automatic Natural ) prompt, press Enter. 

  

 
Sweep along 2 Rails 
Look for this button 
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7 In the Sweep 2 Rails Options dialog box, click OK. 

A surface is created whose edges match the rail curves. 

 

 

To create the housing: 

1 Turn the Housing Surface, Housing Curves, and Mirror layers on. 

2 Make the Housing Surface layer current. 

3 From the Surface menu, click Sweep 2 Rails. 

4 At the Select rail curves prompt, select the two rail curves. 
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5 At the Select cross section curves ( Point ) prompt, select the outer edge of the cylinder, and 
then press Enter. 

6 At the Adjust curve seams ( Flip Automatic Natural ) prompt, press Enter. 

 
7 In the Sweep 2 Rails Options dialog box, click OK. 

A surface is created. 
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To join the two parts: 

1 Select the base and the housing surfaces. 

2 From the Solid menu, click Union. 

The two parts are joined and trimmed. 

 
3 Use the FilletEdge command (Solid menu: Fillet Edge) with a radius of .25 to round the 

intersecting edge. 
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Exercise 58—Using a network of curves to create surfaces 
1 Open the model Networksurf.3dm. 

2 From the Surface menu, click Curve Network. 

3 At the Select curves in network ( NoAutoSort ) prompt, select the two edge curves and the 
cross-section curves, and press Enter. 

 
4 In the Surface From Curve Network dialog box, change the edge matching to Curvature, 

click OK. 

A surface is created that has curvature continuity with the other two surfaces. 
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Exercise 59— Practice using one-rail sweeps: 
In this exercise you use one rail sweeps to make an end table with free-form tapered legs. 

To create the legs: 

1 Open the model Table.3dm. 

2 From the Surface menu, click Sweep 1 Rail. 

3 At the Select rail curve prompt, select the path curve for the leg. 

4 At the Select cross section curves ( Point ) prompt, select the shape curve for both ends of the 
leg. 

5 At the Select cross section curves. Press Enter when done ( Point ) prompt, press Enter. 

 
6 At the Adjust curve seams ( Flip Automatic Natural ) prompt, press Enter. 

 
7 In the Sweep 1 Rail Options dialog box, click OK. 

The table leg is created. Note the nice transition from one cross-section curve to the other. 
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To create the brace: 

1 Change to the Braces layer. 

2 Repeat the previous process to create the brace. 

   

To create the top: 

1 Change to the Top layer. 

2 From the Surface menu, click Sweep 1 Rail. 

3 At the Select rail curve prompt, select the ellipse. 

4 At the Select cross section curves ( Point ) prompt, select the shape curve. 

5 At the Select cross section curves. Press Enter when done ( Point ) prompt, press Enter. 

 
6 In the Sweep 1 Rail Options dialog box, click OK. 

The surface for the rim of top is created. 
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To finish the table: 

1 Select all of the surfaces you created. 

2 From the Solid menu, click Cap Planar Holes. 

Six caps were created. 

  
3 Use Mirror to copy the brace and the leg to finish the model. 

Mirror them around 0,0 in the Top viewport. 

  

  



 

Notes: 

Robert McNeel & Associates 209 

Exercise 60— Creating a toy hammer: 
In this exercise you will use most of the techniques that you’ve learned in the previous sessions.  

Some models require more attention to detail. This is an example of a model that requires precise 
modeling techniques. This exercise also requires a number of different surface creation techniques. 
The technical drawing is included to help you create a very precise model. 

 
1 Open the model Hammer.  

2 The following layers have been created: Construction, Curve, Handle, Tang, Head, Hole, and 
Claw. 

13

16

ALL FILLETS AND ROUNDS 2 MM.
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3 Draw outlines for the hammer in the Top viewport. 

Drawing outlines helps while drawing the curves. You can either draw lines, polylines, or 
rectangles to create the outlines. Use the dimensions on the technical drawing to get accurate 
outlines. 

To create the claw: 

When modeling the shape of the claw, you will use circles, arcs, and curves. You can trim the 
circles and arcs and then join them together to create a closed curve. You can rebuild the curve 
and adjust the control points to get a more sculptural shape.  

1 Change to the Curve layer 

2 Draw a curve defining the shape of the claw in the Top viewport. 

You can use a free-form curve or use a combination of arcs and circles that are trimmed and 
joined to create the curve. Following is a step-by-step approach to creating the curve for the claw 
part of the hammer using arcs and circles. 

Start by drawing two circles. 

3 Use the Circle command (Curve menu: Circle > Tangent to 3 curves) to create a circle at the 
lower end of the claw. 

 Draw the circles tangent to the construction geometry. 

  
4 Use the Circle command (Curve menu: Circle > Tangent, Tangent, Radius) to create a circle at 

the upper end of the claw that is tangent to the upper right corner with a 4 mm radius. 

Draw the circles tangent to the construction geometry.  
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5 Use the Arc command (Curve menu: Arc > Tangent, Tangent, Radius) to create arcs that are 
tangent to the two circles. 

  
6 Use the Trim command (Edit menu: Trim) to trim the inside part of the circles. 

 
7 Use the Join command (Edit menu: Join) to join the arc segments. 

8 Change to the Claw layer. 

9 Select the joined segments. 

10 Use the Extrude command (Solid menu: Extrude > Straight) to extrude the curve on both sides 
of the construction plane. 
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To create the head: 

1 Change to the Curve layer. 

2 Use the Curve command (Curve menu: Free-form > Control Points) to create the curve for the 
cross-section of the head. 

Make sure the curve intersects the claw part. This makes joining the two pieces easier. 

 
3 Change to the Head layer. 

4 Use the Revolve command (Surface menu: Revolve) to revolve the curve. 

 Use the midpoint of the construction line for the revolve axis. 

  
5 Save your model. 

To create slot for the claw part of the hammer: 

1 Use the Curve command (Curve menu: Free-form > Control Points) to draw a curve for the 
slotted part of the claw. 

Make sure the curve is symmetrical.  
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2 Use the Line command (Curve menu: Line > Single Line) to draw a line between the endpoints. 

3 Use the Join command (Edit menu: Join) to join the curve and the line. 

4 Drag the closed curve closer to the claw. 

5 Use the Rotate command (Transform menu: Rotate) to rotate the curve to align more closely with 
the curve of the claw. 

 
6 Change to the Claw layer. 

7 Use the Extrude command (Solid menu: Extrude > Straight) to extrude the curve through the 
claw. 

  
8 Save your model. 

9 Use the BooleanDifference command (Solid menu: Difference) to subtract the slot from the 
claw. 
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To finish the claw: 

1 Use the BooleanUnion command (Solid menu: Difference) to join the head with the claw. 

 
2 Use the FilletEdge command (Solid menu: Fillet Edge) to make the fillets around the top and 

bottom of the claw, the slot, and the intersection between the head and the claw. 

  
3 Save your model. 

To create the shape curve for the tang and the handle: 

Create the shape curve for the tang in the Right viewport. This curve will also be used for the 
handle. 

1 Change to the Curve layer and turn on Ortho. 

2 Use the Curve command (Curve menu: Free-form > Control Points) to draw a curve for the upper 
cross-section of the tang. 

Make sure the curve is symmetrical. 

  
3 Save your model 
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To create the tang: 

1 Use the Curve command (Curve menu: Free-form > Control Points) to draw one of the curves for 
the tang of the hammer. 

Make sure that it intersects the claw. 

  
2 Use the Mirror command (Transform menu: Mirror) to create the other curve. 

3 Change to the Tang layer. 

4 Use the Sweep2 command (Surface menu: Sweep 2 Rails) to make the surface. 

  

To finish the tang:  

1 Use the Mirror command (Transform menu: Mirror) to make the other half of the tang. 

 
2 Select both halves. 

3 Use the Join command (Edit menu: Join) to join the two surfaces. 

4 Select the joined surfaces. 
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5 Use the Cap command (Solid menu: Cap Planar Holes) to make the tang a closed polysurface. 

 
6 Save your model. 

To finish the hammer head: 

1 Select the tang and the claw. 

2 Use the BooleanUnion command (Solid menu: Difference) to join the tang with the claw and the 
head. 

3 Use the FilletEdge command (Solid menu: Fillet Edge) to make the fillets at the intersection 
between the tang and the claw. 

The edge has a round on it. 

 
4 Save your model. 
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To create the handle: 

1 Change to the Curve layer. 

2 Use the Curve command (Curve menu: Free-form > Control Points) to draw a curve for the top 
edge of the handle. 

Make it start at the endpoint of the tang profile curve and end on the centerline. 

  
3 Use the Mirror command (Transform menu: Mirror) to make the other half. 

4 Change to the Handle layer. 

5 Use the Sweep2 command (Surface menu: Sweep 2 Rails) to make the surface using the tang 
curve as the profile curve. 

A surface is created. 

 
6 Select the surface. 

7 Use the Mirror command (Transform menu: Mirror) to make the other half. 

8 Select both halves. 

9 Use the Join command (Edit menu: Join) to join the two surfaces. 
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10 Use the Cap command (Solid menu: Cap Planar Holes) to cap the open end. 

11 Save your model. 

To create the hole for the handle: 

1 Use the Circle command (Curve menu: Circle > Center, Radius) to make a circle 25mm from the 
end of the handle. 

You may have to draw a construction line to help you position the circle. 

2 Use the Extrude command (Solid menu: Extrude > Straight) to extrude the curve on both sides 
of the construction plane. 

Make sure the extrusion intersects both sides of the handle. 

  
3 Save your model. 

4 Use the BooleanDifference command (Solid menu: Difference) to subtract the hole from the 
handle. 

5 Use the FilletEdge command (Solid menu: Fillet Edge) to make the fillets at the edges of the 
hole. 

The edges have rounds on them. 

 
6 Save your model. 
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Exercise 61— Creating a squeeze bottle: 
Some models require more attention to detail. This is an example of a model that requires precise 
modeling techniques. This exercise also requires a number of different surface creation 
techniques.  

The technical drawing is included to help you create a very precise model. 

 

 

1 Start a new model. Use the Inches.3dm template. 

2 Save as Bottle. 

3 Make the following layers: Construction, Curve, Bottle, BottleTop, Threads, Cap1, Cap2, and 
CapTop. 

4 Change to the Construction layer. 
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Create the bottle shape 
To create the bottle shape, you will draw curves that defines the bottom and top edge, and then draw 
a curve that represents the side shape. You will then create a surface from these defining curves. 

To draw the construction curves: 

1 Use the Rectangle command (Curve menu: Rectangle > Corner to Corner) to make rectangles in 
the Front and Right views that define the overall size of the bottle shape of the bottle. 

The rectangles will be used as guides for building the bottle curves. 

  
2 Use the Lock command (Edit menu: Visibility > Lock) to lock the two rectangles. 

3 Use the Ellipse command (Curve menu: Ellipse > From Center) to make the shape for the bottom 
of the bottle. 

4 Snap to the intersection of the rectangles for the center of the ellipse. 

 
5 Use the Move command (Transform menu: Move) to move the ellipse up .25 in the Front view. 

  

 
Rectangle 

 
Ellipse 
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6 Use the Circle command (Curve menu: Circle > Center, Radius) to draw a circle for the top shape 
of the bottle. 

7 Snap to the intersection at the top of the rectangles for the center of the circle. 

 

To draw the edge curve: 

1 Change to the Curve layer. 

2 Use the Curve command (Curve menu: Free-Form > Control Points) to define the edge of the 
bottle in the Front viewport. 

Use the rectangle and object snaps to help you establish the correct size. The curve will be used to 
create the surface of the bottle. 
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To create the surface for the bottle: 

1 Change to the Bottle layer. 

2 Use the Sweep2 command (Surface menu: Sweep 2 Rails) to make the bottle surface 

The ellipse and the circle will be the rails. The curve you created will be the shape curve. 

3 In the Sweep 2 Rails Options dialog box, click OK. 

  

Cap the top and bottom 
If you close the bottle, thereby creating a solid, Rhino can calculate the bottle’s volume. If you were 
creating this bottle in real life, knowing the volume would be important. Normally, a bottle would have 
to be designed to hold a specified volume. 

If the edges of the remaining open surfaces are planar curves, you can use the Cap command to close 
them. The open edges on the bottle are the top circle and the bottom rounded rectangle, and they are 
planar. 

To cap the top and bottom: 

1 Select the surface. 

2 Use the Cap command (Solid menu: Cap Planar Holes) to close the holes. 

 

 
Two-Rail Sweep  

 
Cap Planer Holes  
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Flatten the sides 
You will notice in the Right viewport that the bottle bulges too much. You will create custom surfaces 
to trim the bulges away. 

To create the trimming surface: 

1 Change to the Curve layer. 

2 In the Right viewport, draw two curves to approximate the shape at the edge of the bottle and 
the middle of the bottle. 

3 The technical drawing gives dimensions for these curves, but for this exercise you can use the 
construction rectangles to help. If you would like to go further, try to figure out on your own how 
to draw the curves to the exact specifications. 

  
4 In the Front viewport move the curve with more curvature to align with the edge of larger 

rectangle. 

  
5 Mirror the edge curve to the opposite side. 
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6 Select the three curves you just created. 

7 Use the Loft command (Surface menu: Loft) to make the cutting surface. 

8 In the Loft Options dialog box, click OK. 

A lofted surface intersects the bottle. 

 
9 Mirror the surface to the other side of the bottle. 

 
10 Save your model. 

To remove the surface from the bottle: 

1 Change to the Bottle layer. 

2 Use the Dir command (Analyze menu: Direction) to check the surface normal direction. Flip the 
normals if necessary. 

The normals should be pointing toward the center of the bottle. 

  

 
Loft 
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3 Select the bottle. 

4 Use the BooleanDifference command (Solid menu: Difference) to subtract the two lofted 
surfaces from the bottle. 

The bottle is now a closed solid. 

  
5 Use the FilletEdge command (Solid menu: Fillet Edge) to round off the sharp edges by adding a 

smooth radius between the edges. 

  

 
Boolean Difference 
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Create the bottle’s top 
To create the bottle throat, you are going to revolve a profile curve to create the surface, and then 
subtract threads. 

To create the profile curve: 

1 Change to the Curve layer. 

2 In the Front viewport, use the Lines command (Curve menu: Line > Line Segments) and the Arc 
command (Curve menu: Arc > Center, Start, Angle) to create a profile curve for the outside and 
the inside of the top. 

3 Use the drawing below to draw the correct dimensions. 

 
4 Begin the drawing anywhere in the viewport. 

 You will move it to a precise location after it is made. 

5 Use the Join command (Edit menu: Join) to join the segments together. 
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Tip When drawing line segments, you can use object snaps, the distance constraint, and 
ortho to draw precisely. For example, for the first line type .5,7.25 for the starting point, then 
simply type .25 to constrain the line to .25 units. Turn Ortho on and drag the line to the right 
and click. The line stops at .25 units from the beginning of the line. For the vertical line on the 
left, use the End object snap to pick the end of the first line, type .375 to constrain the 
distance, and drag the line up. 

6 Use the Move command (Transform menu: Move) to move the profile from the midpoint of the 
bottom edge to the quadrant of the top of the bottle. 

 
7 Change to the Bottle Top layer. 

To create the top surface: 

1 Select the profile curve. 

2 Use the Revolve command (Surface menu: Revolve) to make the surface. 

3 In the Revolve Options dialog box, click Delete curve to revolve, and click OK. 

The top is created. 

  

Note: Practice additional surface modeling techniques by creating threads on the bottle top and the 
caps for the model. Use the technical drawing to help. 

 
Revolve 
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Adding the threads 
To add the threads, you will sweep a profile shape along a path drawn with the Helix command. 

To create the path curve helix: 

1 Change to the Curve layer. 

2 From the Curve menu, click Helix. 

3 At the Start of axis ( Vertical AroundCurve ) prompt, snap to the center point at the bottom of 
the area to be threaded. 

4 At the End of axis prompt, snap to the center at the top of the area to be threaded. 

  
 

5 At the Radius and start point <1.000> ( Diameter  Mode=Pitch  Turns=1.25  Pitch=0.25  
ReverseTwist=No ) prompt, click Turns. 

6 At the Number of turns <1.250> prompt, type 1.5 and press Enter. 

7 At the Radius and start point <1.000> … prompt, pick a point near the edge that is slightly 
smaller than the outside edge of the area to be threaded. 

 

 
Helix 
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To draw the thread profile: 

1 Draw a triangle using the Polygon command for the thread as shown below. 

 
2 Select the triangle you created. 

3 From the Transform menu, click Array, and then click Along Curve. 

4 At the Select path curve ( Basepoint ) prompt, select the helix near the bottom. 

5 In the Array Along Curve Options dialog, change the number of items to 5 and click Roadlike. 

 
6 At the Click in a viewport to choose a CPlane prompt, click in the Top viewport. 

It might be a good idea at this point to change your perspective view so you can see the profile 
curves more easily. 
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7 Delete the first and last profile curve. 

   
You will use the remaining profile curves to create a surface. 

To create the thread surface: 

1 Change to the BottleTop layer. 

You can see the helix and profile curves easier if you Hide the bottle top at this point. 

Use the Sweep1 command to create a surface that starts a point at one end of the helix, goes 
through each profile, and ends at a point at the other end of the helix. 

2 From the Surface menu, click Sweep 1 Rail. 

3 At the Select rail curve prompt, select the helix. 

4 To start the surface at a point, at the Select cross-section curves ( Point ) prompt, type P, and 
press Enter. 

5 At the Pick start point prompt, use the End object snap to pick one end of the helix. 

  
6 At the Select cross-section curves ( Point ) prompt, select the profile curves in order. 

7 To end the surface at a point, at the Select cross-section curves ( Point ) prompt, type P, and 
press Enter. 

 
Sweep Along One Rail 
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8 At the Pick end point prompt, use the End object snap to pick the other end of the helix. 

  
9 At the Adjust curve seams ( Flip  Automatic  Natural ) prompt, press Enter. 

10 In the Sweep 1 Rail Options dialog box, change the Style to Roadlike Top, and click OK. 

 
 

11 Show the bottle top.  

  
12 Select the helical thread and the bottle top. 

13 Use the BooleanUnion command (Solid menu: Union) to join the thread and the bottle top. 
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 10  

 

 

 
Importing and 
Exporting Models 

 
Rhino supports many different import and export formats, making it possible to model in Rhino and 
then export your model to downstream processes. For a complete list of import and export options 
refer to Rhino Help. Search the index for “import and export.” 

Importing and Exporting Rhino File Information 
When you export to a format like 3DS, STL or DWG, Rhino has to convert from smooth NURBS 
surfaces to a polygon mesh representation made of triangles. To do a good approximation of the 
curved surfaces, Rhino can sometimes use a lot of polygons. The density of triangles can be adjusted 
when exporting. You can create a mesh object and export it, or Rhino can create the mesh during the 
export process. 

There are two methods to export models to other formats. You can “Save As” and choose a specific 
export format to export an entire model. You can select some objects and “Export Selected” then 
choose a specific export format to export a portion of the model. In the following exercise you will use 
the “Save As” method to export three of the most common file formats.  

Exercise 62— Exporting models 

To export a model to a mesh format: 

1 Open the model Export.3dm. 

2 From the File menu, click Save As. 
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3 In the Save As dialog box, change the Save as type to Stereolithography (*.stl). 

 
4 In the file name box type Export and click Save. 

5 In the STL Export Options dialog box, click Binary, check Export open objects and click OK. 

 
6 In the Polygon Mesh Options dialog box, click Preview. 

 

 

  
Flat shade of the render mesh. 
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7 Adjust the slider to the left for Fewer polygons and click Preview. 

 

  
Flat shade of the mesh. 

 

8 Move slider all the way to the left and Preview. 

 

  
Flat shade of the mesh. 

9 Adjust the slider until you get the desired mesh, then click OK. 

Detailed mesh controls are discussed in more depth in the Level 2 training class. 
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To export a model to IGES: 

1 From the File menu, click Save As. 

2 In the Save As dialog box, change the Save as type to IGES (*.igs). 

3 In the IGES Export Options dialog box, select Pro E Windows solids as the IGES type, click 
Detailed Controls. 

 Detailed controls allows the user more input. 

 

 

 

 

 

4 Click Cancel to terminate, or OK to create the IGES file. 

To export a model to STEP: 

1 From the File menu, click Save As. 

2 In the Save As dialog box, change the Save as type to STEP (*.stp, *.step). 

3 In the STEP Options dialog box, use the default setting. 
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 11  

 

 

 
 
Rendering 

 
Rendering is available for showing your model as if it was photographed. While the Rhino renderer 
may be good enough for much of your work, use another rendering program such as Rhino’s Flamingo 
plug-in for higher quality results. Flamingo is available as a plug-in to Rhino 2.0. Visit 
www.flamingo3d.com for more information. 

Rhino’s renderer uses color, spotlights, displays shadows, and does antialiasing. It also allows the 
attachment of textures and bump maps. In this exercise we will focus on the full rendering capability. 

Exercise 63— Practice rendering a model 
1 Open the model Render.3dm. 

2 From the Render menu, click Current Renderer, then click Rhino Render. 

3 Right click on the Perspective title bar, then click Rendered display. 

 The viewport mimics but does not exactly duplicate what you will get in a Render. 
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To assign a color to the handle: 

1 In the Layers dialog box, click on the Materials column for the Handle layer. 

 
2 In the Material dialog box, click Basic, 

 To give the handle a highlight, change the Reflective finish setting. 

 A highlight of 0 means that the object is not shiny at all and it will not have a specular highlight. A 
low value of highlight makes the shiny spot to be small, and the object will look glossier. As the 
highlight increases in value, the shiny spot gets large—this makes the object look more like it is 
made out of a reflective material. 

 The shiny spot only appears when you are looking at an object at a certain angle relative to the 
angle of the light. 

3 Change the Reflective finish setting to 90, then click the Color swatch. 

 

 
Render 
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4 In the Select Color dialog box, select a color, like Red, and click OK. 

  
5 Repeat the steps above to assign a material to the Blade layer. 

6 From the Render menu, click Render. 

A display window appears with the current viewport rendered in colors, but it will probably lack 
detail. You can close the Display Window without disturbing your model. Placing lights will add 
depth and detail to the rendered image. 
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To place a light: 

Start with a standard lighting scheme. You can experiment to develop your own lighting schemes 
later. 

1 Zoom out in the Top and the Front viewport. 

2 Change to the Lights layer. 

3 From the Render menu, click Create Spotlight. 

4 At the Base of cone ( Vertical  Diameter  3Point  Tangent  AroundCurve ) prompt, pick a point 
near the center of the screwdriver and slightly above it in the Front viewport. 

 
5 At the Radius <1> ( Diameter ) prompt, pick a point so that the radius is larger than the entire 

screwdriver in the Top viewport. 

 
6 At the End of cone prompt, hold down the control key, and pick a point below and to the left in 

the Top viewport. 

This starts elevator mode. 

 

 
Spotlight 
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7 At the End of cone prompt, click above the object in the Front viewport. 

This will be your main light. 

 
8 Click in the Perspective viewport. 

9 From the Render menu, click Render. 

The image has some highlights and shadows. 

 

To place a second light: 

1 Zoom out in the Top and the Front viewport. 

2 From the Render menu, click Create Spotlight. 

3 At the Base of cone ( Vertical ) prompt, pick a point to the right and slightly below the 
screwdriver and covers about half of it in the Top viewport. 

4 At the Radius <1> ( Diameter ) prompt, pick a point so that the radius is larger than the entire 
screwdriver in the Top viewport. 



 

Notes: 

Robert McNeel & Associates 242 

5 At the End of cone prompt, click to the right and slightly below the object in the Top viewport. 

This will be your secondary (fill) light. 

 

To assign properties to the light: 

1 Select the new light. 

2 From the Edit menu, click Object Properties. 

3 On the Light page, change the Shadow intensity to 30 and the Spotlight hardness to 60. 

 Experiment with these settings to get the desired effect. 

  
4 Click in the Perspective viewport. 

5 From the Render menu, click Render. 
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To add a bumpy surface to the handle: 

1 In the Layers dialog box, click on the Materials column for the Handle layer. 

 
2 In the Material dialog box, click the Bump button. 

   
You can use any bitmap file for a bump. The bumps come from the pattern of light and dark in the 
bitmap image. 

3 In the Open Bitmap File dialog box, select Pattern.jpg, then click Open. 

4 Click OK to close the Material dialog box. 
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5 From the Render menu, click Render. 

The surface of the handle has a bumpy appearance. 

 

To add a texture to the handle: 

1 In the Layers dialog box, click on the Materials column for the Handle layer. 

2 In the Material dialog box, clear the Bump field. 

3 In the Material dialog box, click the Texture button. 

  
4 In the Open Bitmap File dialog box, select Wood.jpg, then click Open. 

5 Click OK to close the Material dialog box. 
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6 From the Render menu, click Render. 

The surface of the handle is textured with a wood grain texture. 

 

To make the handle transparent: 

1 In the Layers dialog box, click on the Materials column for the Handle layer. 

2 In the Material dialog box, clear the Texture field. 

3 In the Material dialog box, change the Transparency setting to 50. 
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4 From the Render menu, click Render. 

 The handle will look transparent. 

  

To add a surface for a ground plane: 

1 Use the Plane command (Surface menu: Plane > Corner to Corner) to draw a flat surface in the 
Top viewport. 

  
2 Select the surface. 

3 Use the Properties command (Edit menu: Object Properties...) on the Material page, click 
Basic. 
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4 In the Texture section assign the Wood.jpg to the plane.  

 

 

5 From the Render menu, click Render. 

Rendering with Flamingo 
In this part of the exercise you will use Flamingo to assign materials from the material library and set 
up an environment. You will use the same lights and model. 

To assign a material: 

1 Select the flat surface. 

2 Use the Hide command (Edit menu: Visibility > Hide) to hide it. 

3 From the Render menu, click Current Renderer, then click Flamingo Raytrace. 

4 In the Layers dialog box, click on the Materials column for the Handle layer. 

5 In the Material dialog box, click Plug-in, then click Browse. 

6 In the Material Library dialog box, in the Plastics library, in the Transparent folder, select a 
material, then press OK. 

7 In the Material dialog box, press OK. 

8 Repeat this process for the Blade layer. 

9 Choose a shiny metal material, like Metal\Steel\Polished\Plain. 
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10 Render the model. 

  

To set up an environment: 

1 Use the Options command (Tools menu: Options...) to setup the Flamingo environment options 

2 In the Rhino Options dialog box, on the Flamingo page, click the Environment button. 

3 On the Environment dialog box, change to a 3 Color Gradient. 

 Use the default setting. 

4 Check the Ground Plane check box. 

5 On the Ground Plane page, click the Material button, and select a material for the ground plane, 
like Metal\Aluminum\Satin\Checker Plate. 

6 On the Environment dialog box, press OK. 

7 On the Rhino Options dialog box, press OK. 

8 Render the model. 

 Notice that you also get reflections. 

  
 Flamingo rendering is covered in more depth in Level 2 training. 

 For extra practice use the canoe you made in the loft exercise. 



 

Notes: 

Robert McNeel & Associates 249 

12  

 

 

 
 
Dimensions 

Dimensions 
You can create simple dimensions that are visible when you are looking at the plan view of the 
construction plane. 

Dimension Types 

 

Button Command Description 

 

Dim Creates a horizontal or a vertical dimension. 

 

DimAligned Creates an aligned dimension. 

 

DimRotated Creates a rotated dimension. 
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Button Command Description 

 

DimAngle Creates an angular dimension. 

 

DimRadius Creates a radius dimension. 

 

DimDiameter Creates a diameter dimension. 

 

Text Creates 2-D annotation text. 

 

Leader Draw an arrow leader. 

 

Properties Edit dimensions and text. 

 

DimRecenterText Returns text that has been moved away from its default position to its original 
location. 

 

Make2-D Creates curves from the selected objects as silhouettes relative to the active 
construction plane. The silhouette curves are projected flat and then placed on 
the world x,y-plane. 

Exercise 64— Practice dimensioning 
1 Open the model Dimension.3dm. 

2 From the File menu, click Properties. 
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3 In the Rhino Options dialog box, on the Dimensions page, make the following changes. 

 
4 From the Dimension menu, click Linear Dimension. 

5 At the First dimension point ( Style ) prompt, snap to the lower left end of the part in Top 
viewport. 

6 At the Second dimension point prompt, snap to the lower right end of the part in the Top 
viewport. 

7 At the Dimension location ( Vertical  Horizontal ) prompt, pick a point below the part in the Top 
viewport. 

 

Use object snaps to locate the 
extension line origins. 
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8 From the Dimension menu, click Radial Dimension. 

9 At the Select curve for radius dimension ( Style ) prompt, select the lower left quadrant of the 
arc in the Front viewport. 

10 At the Dimension location prompt, click to place the dimension text. 

 
11 Dimension the rest of the drawing using leaders, text blocks, horizontal, vertical, radius, and 

diameter dimensions. 

  
12 Save your model. 

Making a 2-D Drawing from a 3-D Model 
Rhino has the ability to generate a two-dimensional drawing from a three-dimensional model, by 
projecting the geometry to the world coordinate plane, and aligning the views. Options for first angle 
projection or third angle projection are available. In addition to the three orthographic views, a 
two-dimensional perspective drawing is also generated. Hidden lines are removed and placed on a 
separate layer. 

Options for creating four views: three parallel viewports and a perspective viewport, or single views of 
individual viewports are supported.  

The Make2D command makes a two-dimensional drawing for all four views.  

To move extension line or text 
locations for dimensions, turn on 
control points for the dimension 
and move the control points. 
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Exercise 65— Practice making a 2-D drawing for export  
1 Open the model Make2D.3dm. 

2 From the Dimension menu, click Make 2-D Drawing. 

3 In the Make2D Options dialog box, click 4-view (USA) and check Show hidden lines, and 
then click OK. 

 
The 2-D drawings are created on the Top CPlane near the origin on the world xy plane. View them 
in the Top viewport. 

 
4 Dimension the 2D drawing. 
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To export the 2-D drawing to AutoCAD: 

1 Select the 2-D geometry and the dimensions. 

2 From the File menu, click Export Selected. 

3 Change the Save as type to AutoCAD DWG, the File name to Bracket.dwg, then click Save. 

4 In the AutoCAD Export Options dialog box, AutoCAD Version 2000, Save Curves as 
Polylines,  Save Surfaces as Polygon meshes, Save Polygon meshes as Polyface meshes, 
check Use Simple Entities, click OK. 

 
The 2-D geometry, layers and dimensions are translated to AutoCAD’s .DWG format. 
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Printing 

 
Printing a wireframe image of your model directly from Rhino is supported. Options for scaling and 
printing in color are available. Images in the current viewport or all viewports can be printed. Rhino 
uses your windows printing device for output. While printing to scale is supported, hidden line removal 
is not supported. Use the Make2D command to generate hidden-line views to print. 

Exercise 66— Practice printing 
1 Open the model Printing.3dm. 

2 Click in the Top viewport. 

3 From the File menu, click Print Setup. 

4 In the Print Setup dialog box, click Landscape, adjust any other options appropriate for your 
printer or plotter, then click OK. 

 
5 From the File menu, click Print.   
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6 In the Print dialog box, choose the following settings: 

 Under Print area, click View. 

 Under Print scale, select Scaled to Fit. 

 Under Print offset click Center objects on paper. 

7 Click OK. 

 The Top viewport will be printed. 
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To print the current viewport to a scale: 

1 From the File menu, click Print. 

2 In the Print dialog box, change Print scale to 1:20, then click OK. 

To print a rendered image: 

1 Open the model Render.3dm. 

2 From the Render menu, click Render. 

3 In the render window, from the File menu, click Print. 

The rendered image will be printed to your default Windows printing device, which may be 
different from what you set in Print Setup. 

 
 





 

  

Part Four: 
Customizing Workspaces and Toolbars 
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Rhino Settings 

Options 
The Rhino Options dialog box displays most of the settings that affect your modeling environment. 
Use it to toggle the settings or redefine them.  

The Document Properties settings are saved with the Rhino model. The Rhino Options settings are 
saved in the Windows registry and affect every Rhino model. 

Exercise 67— Practice with options 

To change modeling aids: 

1 From the Tools menu, click Options.  

2 In the Rhino Options dialog box, click the Modeling Aids page. 

 The Modeling Aids page controls Grid Snap, Ortho, Planar mode, and Object Snap options. 

 These options can be toggled on and off from the dialog box or from the status bar. To change the 
options for Ortho or object snap, type new values in the boxes. In an earlier exercise you changed 
the Ortho setting so that it snapped every 30 degrees. 

 In the object snap area, Project object snap to CPlane projects the snap point to the 
construction plane even though the object snap point might be in 3-D space. 

To change Rhino’s screen appearance: 

1 Click the Appearance page. 

 The Appearance page controls the appearance of the Rhino window. 

 
Options 
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2 Click the gray rectangle next to Background color and change it to a different color. 

3 Check the Crosshairs box. 
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To change or create shortcuts: 

1 Open the Keyboard page. 

The Keyboard page sets up shortcut keys for Rhino commands. 

 
2 Type DisableOsnap in the box next to the F4 key. 

This gives you a key that toggles your persistent object snaps between on and disabled.  
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To change or create command aliases: 

1 Click the Aliases page. 

The command Aliases page allows the user to create custom aliases for Rhino commands. 

2 Click New. 

A cursor moves into the white area of the dialog box. 

 
3 Type L, then press the tab key. 

4 Type ! Lines. 

The exclamation point acts as a cancel. 

Now you will be able to type L and press Enter at the command line, to begin the Lines 
command. 

To change view options: 

Click the View page. 

The View page has pan, zoom, rotate, and redraw controls. 
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To change general options: 

Click the General page. 

The General page the number of undos retained in memory, startup commands, recent command 
list limit, AutoSave control, and do not repeat commands, default isocurve density for new 
surfaces. 

To set file options: 

1 Click the Files page. 

The Files page sets the location of template files and the autosave files. 

2 Click OK to close the Options dialog box. 

3 Try the Lines alias and the DisableOsnap toggle.  

Note how your cursor has changed. 

Document Properties 
Document properties are all of the settings that are saved with the Rhino model.  

Exercise 68— Practice with document properties 

To change the grid: 

1 From the File menu, click Properties. 

2 Click the Grid page. 

The Grid page configures grid, grid axes, and axis icons. You changed the snap spacing in an 
earlier exercise. 

To change render options: 

1 Click the Rhino Render or Flamingo page. 

The Render page controls most of the render options. 

2 Click the Mesh page. 

This page controls the mesh properties. It will also affect performance. 

To set units: 

Click the Units page. 

The Units page controls the unit system and the tolerance settings. 

 
Document Properties 
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Custom Toolbar Layouts 

 
The toolbar layout is the arrangement of toolbars containing command buttons on the screen. The 
toolbar layout is stored in a toolbar collection file that you can open and save. Rhino comes with a 
default toolbar layout, and automatically saves the active toolbar layout before closing. You can create 
your own custom layouts and save them for later use. 

You must use an external file manager to delete a toolbar collection file.  

Exercise 69— Customizing a toolbar layout 
1 Begin a new model. 

2 From the Tools menu, click Toolbar Layout. 

3 In the Toolbars dialog box, click Save As. 

4 In the Save Workspace As dialog box, in the File name box type Level 1, and click Save. 

A new toolbar collection file has been created. Toolbar collection files are saved with a .ws3 
extension. You will use this new toolbar collection to do some customization. 
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To show another toolbar: 

1 From the Tools menu, click Toolbar Layout. 

 
2 In the Toolbars dialog box, check Curve Tools to show the toolbar. 

3 In the Toolbars dialog box, clear Curve Tools to hide the toolbar. 

4 Show the Curve Tools toolbar again, then click Close. 



 

Notes: 

Robert McNeel & Associates 269 

5 To dock the Curve Tools toolbar at the right, drag it to the right edge until it changes to a vertical 
shape, then releasing your mouse button. 

 

To save your toolbar layout: 

In the Toolbars dialog box, from the File menu, click Save. 
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To create a new toolbar: 

1 From the Tools menu, click Toolbar Layout. 

2 In the Toolbars dialog box, from the Toolbar menu, click New. 

3 In the Toolbar Properties dialog box, in the Name box, type Test, and click OK. 

A new toolbar is created with one blank button in it. 

 

 

4 Close the Toolbars dialog box.  

To edit the new button: 

1 Hold down the Shift key and right-click the blank button. 

 
2 To enter the tooltips for the left and right mouse buttons, in the Edit Button dialog box, under 

Tooltips, in the Left edit box, type Change Last Object to Layer. 

 In the Right edit box, type Change All Curves to Layer. 
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3 In the Left mouse button command box, type ! SelLast ChangeLayer. 

4 In the Edit Button dialog box, in the Right mouse button command box, type ! SelCrv 
ChangeLayer. 

 
5 Click Edit Bitmap. 

6 In the Edit Bitmap dialog box, make a picture for the button face image, and click OK. 

 
7 In the Edit Button dialog box, click OK. 
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To copy a button from one toolbar to another: 

1 From the Standard toolbar, flyout the Layer toolbar, and tear it off. 

2 While holding down the Ctrl key, drag the button you just created to the layer toolbar and drop it. 

 

To add a button to a toolbar: 

1 From the Tools menu, click Toolbar Layout. 

2 In the Toolbar dialog box, check the Test toolbar in the list to show the toolbar. 

3 Click New Button. 

A blank button is added to the Test toolbar. 

4 Close the dialog box. 

Many toolbar functions are available by right-clicking a toolbar’s titlebar. 
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To open the standard toolbar layout: 

1 From the Tools menu, click Toolbar Layout. 

2 In the Toolbars dialog box, from the File menu, click Close. 

3 In the Save Changes dialog box, click Yes. 

4 In the Toolbars dialog box, from the File menu, click Open. 

5 Select Default.ws3, and click Open. 

 

 


